Bug 466896 - busybox rpm aborting when requested to install package
busybox rpm aborting when requested to install package
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: busybox (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ivana Varekova
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 08:18 EDT by Petr Muller
Modified: 2016-09-19 22:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes memory corruption, errors on nonexistent usernames, mishandling of hardlinks in cpio and bogus varnings out of mkdir("/dir/already/exists") (11.07 KB, patch)
2008-10-17 09:27 EDT, Denys Vlasenko
no flags Details | Diff

  None (edit)
Description Petr Muller 2008-10-14 08:18:09 EDT
Description of problem:
I've bricked a box when testing glibc, by removing glibc. Because I'm a smart guy, I had glibc rpms downloaded, and busybox isntalled for this purpose, just in case. So I've tried to fix things easily:

# busybox rpm -i glibc-2.5-24.i686.rpm

which kabooms like this:
*** glibc detected *** busybox: malloc(): memory corruption: 0x085c5d20 ***
======= Backtrace: =========
[0x8146e18]
[0x81483cb]
[0x80febb4]
======= Memory map: ========
00800000-00801000 r-xp 00800000 00:00 0          [vdso]
08048000-0823b000 r-xp 00000000 fd:00 10584066   /sbin/busybox
0823b000-0823e000 rw-p 001f2000 fd:00 10584066   /sbin/busybox
0823e000-0830e000 rw-p 0823e000 00:00 0
085c4000-085e6000 rw-p 085c4000 00:00 0
b7c00000-b7c24000 rw-p b7c00000 00:00 0
b7c24000-b7d00000 ---p b7c24000 00:00 0
b7d25000-b7d4b000 r--p 00000000 00:18 83198326   /mnt/qa/scratch/i386-5c-m1/2009:8182/tps/glibc-2.5-24.i686.rpm
b7d4b000-b7f4b000 r--p 00000000 fd:00 463506     /usr/lib/locale/locale-archive
bfec1000-bfed7000 rw-p bfec1000 00:00 0          [stack]
Aborted

Version-Release number of selected component (if applicable):
# rpm -q busybox
busybox-1.2.0-4.el5.i386

How reproducible:
always, at least on i386.
on x86, I see 'Segmentation fault' wih glibc packages in cca 50% cases

Steps to Reproduce:
1. busybox rpm -i glibc-2.5-24.i686.rpm (can be even rhel5.3's 2.5-29 glibc)
2. see the abort
  
Actual results:
abort, segfaults & friends

Expected results:
my box breathing fresh glibc again

Additional info:
It seems like only glibc packages aborts busybox. I've tried few more, not seeing the problems
Comment 1 Denys Vlasenko 2008-10-17 09:27:34 EDT
Created attachment 320662 [details]
Fixes memory corruption, errors on nonexistent usernames, mishandling of hardlinks in cpio and bogus varnings out of mkdir("/dir/already/exists")
Comment 8 errata-xmlrpc 2009-09-02 05:09:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1249.html

Note You need to log in before you can comment on or make changes to this bug.