Bug 466911 - Text is output when in "quiet" mode
Text is output when in "quiet" mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 09:57 EDT by James Antill
Modified: 2009-01-20 16:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:44:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-10-14 09:57:41 EDT
Description of problem:
 If you do: "yum -e 0 -d 0 update -y" then yum shouldn't output text unless it really has to. 3.2.19-10 outputs the rpm callback text.

 It's a regression, which might affect some people (running the above from cron), and the fix is a one liner:

diff --git a/output.py b/output.py
index 047576e..cb9d1b9 100644
--- a/output.py
+++ b/output.py
@@ -1041,7 +1041,7 @@ class YumCliRPMCallBack(RPMBaseCallback):
         RPMBaseCallback.__init__(self)
         self.lastmsg = None
         self.lastpackage = None # name of last package we looked at
-        self.output = True
+        self.output = logging.getLogger("yum.verbose.cli").isEnabledFor(logging
         
         # for a progress bar
         self.mark = "#"

...which is upstream.

Version-Release number of selected component (if applicable):
3.2.19-10

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2008-10-14 10:01:25 EDT
Re posting the patch:

diff --git a/output.py b/output.py
index 047576e..cb9d1b9 100644
--- a/output.py
+++ b/output.py
@@ -1041,7 +1041,7 @@ class YumCliRPMCallBack(RPMBaseCallback):
         RPMBaseCallback.__init__(self)
         self.lastmsg = None
         self.lastpackage = None # name of last package we looked at
-        self.output = True
+        self.output = logging.getLogger("yum.verbose.cli").isEnabledFor(logginglevels.INFO_2)
         
         # for a progress bar
         self.mark = "#"
Comment 2 RHEL Product and Program Management 2008-10-14 10:26:00 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Dmitry Butskoy 2008-10-15 08:57:22 EDT
This issue also affects all current version of Fedora (since Fedora 8).

The "extra" output itself is insipred by the internal use of python-urlgrabber, which recently was patched by "urlgrabber-progress-ui.patch" (the actual code which prints comes from this patch). 

Should I create a separate bugzilla ticket for Fedora?
Comment 4 James Antill 2008-10-15 10:24:30 EDT
Dmitry, are you talking about a different problem? ... can you show a paste of what it does vs. what it used to do (or what it should be doing).
 AFAIK nothing was changed in urlgrabber that would affect what level the user sees things at (it should have just been a "cosmetic" update, for that patch).
Comment 5 Dmitry Butskoy 2008-10-15 10:37:50 EDT
Well,
when I run

yum -d 0 -e 0 -q -y --downloadonly --downloaddir=/var/spool/updates update

from my cron job, I see two lines of output:

--------------------------------------------------------------------------------
Total                                           9.7 MB/s |  16 MB     00:01


According to the yum-3.2.19 source, the output is from outpyt.py:884, from 
"download_callback_total_cb" method.

By a fragment:

        if not hasattr(urlgrabber.progress, 'TerminalLine'):
            return

I guessed that it is related to urlgrabber, and 'TerminalLine' etc. was introduced by a (non-upstream?) patch to urlgrabber.

Perhaps my discovering is too approximately, and it is not an issue of urlgrabber at all. Anyway, I've found a place in the source... ;)
Comment 6 James Antill 2008-10-15 11:01:58 EDT
This is fixed in upstream and in yum-3.2.19-10 in the RHEL-5.3 candidate (patch: yum-total-download-cb-log.patch).
Comment 13 errata-xmlrpc 2009-01-20 16:44:24 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0176.html

Note You need to log in before you can comment on or make changes to this bug.