Bug 466933 - b43 problems: b43-phy0 ERROR: PHY transmission error
b43 problems: b43-phy0 ERROR: PHY transmission error
Status: CLOSED DUPLICATE of bug 440544
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 11:46 EDT by Daniel Riek
Modified: 2008-11-12 09:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 09:39:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2008-10-14 11:46:35 EDT
Description of problem:

Not sure if this is a problem with WEP in general or a specific access point:

If using a wireless network with WEP encryption in this network, the b43 driver looses the connection after a short time. The log shows a number of the following lines right before the connection is lost:
> b43-phy0 ERROR: PHY transmission error

This happens with manually set up networks as well as when using NetworkManager. If NetworkManager is running, the log also shows lines like:
Oct 14 11:27:56 winterhill kernel: b43-phy0 ERROR: PHY transmission error
Oct 14 11:27:59 winterhill NetworkManager: <info>  (wlan0): supplicant connection state change: 7 -> 0
Oct 14 11:27:59 winterhill NetworkManager: <info>  (wlan0): supplicant connection state change: 0 -> 2
Oct 14 11:28:00 winterhill NetworkManager: <info>  (wlan0): supplicant connection state change: 2 -> 4
Oct 14 11:28:00 winterhill NetworkManager: <info>  (wlan0): supplicant connection state change: 4 -> 7
Oct 14 11:28:00 winterhill NetworkManager: <info>  (wlan0): supplicant connection state change: 7 -> 3
Oct 14 11:28:01 winterhill NetworkManager: <info>  (wlan0): supplicant connection state change: 3 -> 4
Oct 14 11:28:01 winterhill NetworkManager: <info>  (wlan0): supplicant connection state change: 4 -> 7

This continues with multiple repetitions until NetworkManager tries do re-negotiate the the connection (and the nm-applet goes back into connection mode). The re-connect will fail until the b43 module is unloaded and reloaded.


Version-Release number of selected component (if applicable):
Kernel is  2.6.26.5-45.fc9.x86_64
firmware version 410.2160 (2007-05-26 15:32:10)

How reproducible:
Always

Steps to Reproduce:
1. Connect to the WEP encrypted wlan.
2. Connect to some webpage.
3. Watch the errors in /var/log/messages
Comment 2 Daniel Riek 2008-10-14 11:48:23 EDT
The problem does not show whit the same machine connected to a WPA2 network I have access to.
Comment 3 Daniel Riek 2008-10-14 11:49:02 EDT
The hardware is:

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 01)
	Subsystem: Dell Unknown device 0007
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at ecffc000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 2
	Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
	Capabilities: [d0] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting <?>
	Capabilities: [13c] Virtual Channel <?>
	Kernel driver in use: b43-pci-bridge
	Kernel modules: ssb
Comment 4 John W. Linville 2008-10-23 13:53:42 EDT
Michael, anything Daniel can capture to help with this issue?  I know this has been a nagging problem that is usually superficial, but in this case it seemed to have dropped a connection?
Comment 6 John W. Linville 2008-10-23 14:05:37 EDT
Daniel, where did you get your b43 firmware?
Comment 7 John W. Linville 2008-10-24 14:46:36 EDT
Daniel, please follow the directions at the link below:

http://marc.info/?l=linux-wireless&m=122487345432768&w=2

Does this improve things for you?
Comment 8 John W. Linville 2008-11-12 09:39:19 EST

*** This bug has been marked as a duplicate of bug 440544 ***

Note You need to log in before you can comment on or make changes to this bug.