Bug 466963 - CLI Installer for proxy fails for hosted proxy Error: Requested version (5.2) can never be greater than the upstream API version (5.0)
CLI Installer for proxy fails for hosted proxy Error: Requested version (5.2)...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Brandon Perkins
:
Depends On:
Blocks: 446878
  Show dependency treegraph
 
Reported: 2008-10-14 15:14 EDT by Preethi Thomas
Modified: 2008-11-05 13:42 EST (History)
1 user (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:42:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-10-14 15:14:12 EDT
Description of problem:
Command Line Installer for proxy fails for hosted proxy with Error: Requested version (5.2) can never be greater than the upstream

Version-Release number of selected component (if applicable):
5.2.0

How reproducible:
always

Steps to Reproduce:
1. Register a Rhel4 or Rhel5 client system to webqa.
2. Give the system provisioning entitlement and subscribe it to the tools channel.
3. Install proxy-installer package on the client.
4.  Run /usr/sbin/configure-proxy.sh
5. Enter the required information.
  
Actual results:
API version: 5.0.8
ERROR: Requested version (5.2) can never be greater than the upstream
       API version (5.0)
Proxy activation failed! Configuration interrupted.


Expected results:

Proxy installed and functional.

Additional info:
[root@rlx-3-24 ~]#  /usr/sbin/configure-proxy.sh
Proxy version to activate [5.2]: 
RHN Parent [xmlrpc.rhn.webqa.redhat.com]: 
Traceback email []: pthomas@redhat.com
Use SSL [1]: 
CA Chain [/usr/share/rhn/RHNS-CA-CERT]: 
HTTP Proxy []: 
Regardless of whether you enabled SSL for the connection to the RHN Parent
Server, you will be prompted to generate an SSL certificate.
This SSL certificate will allow client systems to connect to this RHN Proxy
securely. Refer to the RHN Proxy Installation Guide for more information.
Organization: Red Hat
Organization Unit [rlx-3-24.rhndev.redhat.com]: RHEN
Common Name [rlx-3-24.rhndev.redhat.com]: 
City: Raleigh
State: NC
Country code: US
Email [pthomas@redhat.com]: 
API version: 5.0.8
ERROR: Requested version (5.2) can never be greater than the upstream
       API version (5.0)
Proxy activation failed! Configuration interrupted.
Comment 1 Brandon Perkins 2008-10-14 16:49:31 EDT
So, looks like we never actually dealt with this in 5.1 as Corey and I thought.  We ignored it per:

https://bugzilla.redhat.com/show_bug.cgi?id=433402#c2

So, now it appears that it is going to bite us again.  I'm placing this on sat520-triage so everyone is aware of it, and so we can come up with a plan.

Luckily the command-line installer is still a tech-preview for 5.2, so if we punt this to 5.3 that is fine.  However, we should document this limitation.

If we want to address this sooner, do we fix it on the Proxy side or the Hosted side?

Regardless, this will definitely be a blocker for 5.3, but I want to get a plan together now.
Comment 2 Miroslav Suchý 2008-10-15 06:10:27 EDT
In 5.1 we did not ignore it, since we did not use rhn-proxy-activation for proxy activation.
This bug should be fixed fast, since I already fixed this issue in spacewalk git repo. I will do the backport to 5.2.
Comment 3 Miroslav Suchý 2008-10-15 07:03:13 EDT
Committed revision 177874.
Package proxy-installer-5.2.0-18 built
Comment 4 Preethi Thomas 2008-10-15 13:41:17 EDT
verified
Comment 5 Steve Salevan 2008-10-27 12:14:15 EDT
Verified on Stage, moving to RELEASE_PENDING.
Comment 6 Brandon Perkins 2008-11-05 13:42:48 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.