Bug 466987 - [RHEL5.3] r500 driver in xorg causes grabbled video.
[RHEL5.3] r500 driver in xorg causes grabbled video.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
:
Depends On:
Blocks: 364381
  Show dependency treegraph
 
Reported: 2008-10-14 17:46 EDT by Jeff Burke
Modified: 2009-01-20 16:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:39:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (52.75 KB, text/plain)
2008-10-15 16:58 EDT, Jeff Burke
no flags Details
rom file (59.50 KB, application/octet-stream)
2008-10-15 19:37 EDT, Jeff Burke
no flags Details
fix for hdmi and vga sharing DDC. (4.82 KB, patch)
2008-11-11 00:50 EST, Dave Airlie
no flags Details | Diff
Xorg.0.log file with xorg-x11-drv-ati-6.6.3-3.20.el5 (48.81 KB, text/plain)
2008-12-02 11:05 EST, PaulB
no flags Details
Xorg.0.log from scratch, xorg-x11-drv-ati-6.6.3-3.21.el5.x86_64.rpm (48.81 KB, text/x-log)
2008-12-03 12:09 EST, PaulB
no flags Details
Xorg.0.log from second scratch build (43.27 KB, text/plain)
2008-12-04 10:51 EST, Jeff Burke
no flags Details
Xorg.0.log file with xorg-x11-drv-ati-6.6.3-3.20.el5.da.1.x86_64.rpm (47.29 KB, text/plain)
2008-12-05 09:47 EST, PaulB
no flags Details
Xorg.0.log file after installing the xorg-x11-drv-ati-6.6.3-3.21.el5.x86_64.rpm. (57.42 KB, text/x-log)
2008-12-09 14:48 EST, PaulB
no flags Details

  None (edit)
Description Jeff Burke 2008-10-14 17:46:59 EDT
Description of problem:
 Installing a system with a ATI Visiontek 2400Pro PCIe 256mb videocard. results in garbled video when firstboot starts.

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20081012.nighlty both i386 and x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install a system with the above card and distro. The system setup the system using the r500 driver in xorg.conf
  
Actual results:
 Screen is bouncy, garbled and fuzzy. Makes it impossible to read.

Expected results:
 This card is supported in RHEL5.2/5.3 This should work out of the box.

Additional info:
 Once the system is installed. I manually went in an changed the xorg.conf file and changed Section "Device", Driver to vesa and was able to continue with the firstboot of the install.
Comment 1 Jeff Burke 2008-10-14 17:47:40 EDT
01:00.0 VGA compatible controller: ATI Technologies Inc RV610 video device [Radeon HD 2400 PRO] (prog-if 00 [VGA controller])
        Subsystem: VISIONTEK Unknown device 3210
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 2: Memory at fe9f0000 (64-bit, non-prefetchable) [size=64K]
        Region 4: I/O ports at b000 [size=256]
        Expansion ROM at fe9c0000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express Legacy Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <4us, L1 unlimited
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s L1, Port 0
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x16
        Capabilities: [a0] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
Comment 3 Cameron Meadors 2008-10-15 11:20:19 EDT
Works fine for me on RHEL5.3-Client-20081006.0 x86_64 with the following card

01:05.0 VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Seri
es] (prog-if 00 [VGA controller])
        Subsystem: Foxconn International, Inc. Unknown device 0e0a
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
ping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size: 4 bytes
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 2: Memory at fdef0000 (64-bit, non-prefetchable) [size=64K]
        Region 4: I/O ports at de00 [size=256]
        Region 5: Memory at fdd00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot
-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable
-
                Address: 0000000000000000  Data: 0000


I did notice that DRI is disabled.  Don't know if that matters.  I am filing a bug for that.

(EE) R500(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.
Comment 4 Dave Airlie 2008-10-15 15:48:09 EDT
can we get a /var/log/Xorg.0.log from the rv610 case?

I've ran this on my rv610 and it seemed fine.
Comment 5 Cameron Meadors 2008-10-15 16:11:22 EDT
tburke will have to get the log for you, but from what I saw, the problem was that X was picking a mode that the monitor could not display.  I added Modes "1024x768" to the xorg and X worked, "1280x1024" did not.  The monitor was 4x3 vga.  The one I was using was 16x9 dvi and vga.
Comment 6 Jeff Burke 2008-10-15 16:58:46 EDT
Created attachment 320486 [details]
Xorg.log

Here is the information requested
Comment 7 Dave Airlie 2008-10-15 17:22:01 EDT
it appears to be a buggy BIOS on this card.

What connectors does the card have and what monitors are plugged in.

Can I get a copy of the BIOS attached?

cd /sys/bus/pci/devices/<pciid>/
echo 1 > rom
cat rom > /tmp/rom
echo 0 > rom

hopefully works on a RHEL kernel, attach the rom here.
Comment 8 Jeff Burke 2008-10-15 17:36:48 EDT
rom: BIOS (ia32) ROM Ext. IBM comp. Video (119*512)
Comment 9 Dave Airlie 2008-10-15 18:41:09 EDT
please attach the rom file, that looks like the output of file on the ROM file.
Comment 10 Jeff Burke 2008-10-15 19:37:13 EDT
Created attachment 320499 [details]
rom file

rom file .... I think
Comment 11 Dave Airlie 2008-10-16 05:15:56 EDT
I've asked AMD to take a look at this.

Its a specific problem with only make/model of card due to the BIOS having what looks to be an incorrect linking of the VGA and HDMI ports DDC lines.

We may have to add a workaround to detect the analog/digital bits or load detect the outputs to check where the monitor is actually plugged in.

So we should hopefully be able to get a fix for RHEL 5.3 final.
Comment 12 Ben Levenson 2008-10-24 16:50:50 EDT
(In reply to comment #11)

> So we should hopefully be able to get a fix for RHEL 5.3 final.
Comment 14 Dave Airlie 2008-11-06 17:24:19 EST
should be fixable by deadline. I just need to code a workaround for the wierd BIOS.
Comment 15 Dave Airlie 2008-11-06 21:02:06 EST
please test the packages at:

http://people.redhat.com/airlied/radeon/

to see if they fix the issues, still waiting for pm_ack.
Comment 16 Dave Airlie 2008-11-11 00:50:09 EST
Created attachment 323151 [details]
fix for hdmi and vga sharing DDC.

no acks yet so heres the patch for now.
Comment 18 Dave Airlie 2008-11-12 01:24:53 EST
MODIFIED

xorg-x11-drv-ati-6.6.3-3.20.el5
Comment 21 PaulB 2008-11-26 11:04:45 EST
Dave, 
Using the same system that the bug was reported with the new package (xorg-x11-drv-ati-6.6.3-3.20.el5) produces the same garbled output as it did before.
PaulB
Comment 23 Dave Airlie 2008-11-26 16:08:56 EST
Paul,

Can we get xorg log file from the system with the updated driver?
Comment 24 Jonathan Blandford 2008-12-02 10:26:24 EST
Paul, can you attach the xorg log?
Comment 26 PaulB 2008-12-02 11:05:46 EST
Created attachment 325388 [details]
Xorg.0.log file with  xorg-x11-drv-ati-6.6.3-3.20.el5

Dave,
The file you requested is attached.
PaulB
Comment 27 Dave Airlie 2008-12-02 16:35:54 EST
its a regression in that the vesa probably worked.

http://porkchop.devel.redhat.com/brewroot/scratch/airlied/task_1595784/

Paul can you try the packages from that scratch build?
Comment 28 PaulB 2008-12-02 16:48:10 EST
Dave,
I'll test it and update the bz.
PaulB
Comment 29 PaulB 2008-12-03 12:09:08 EST
Created attachment 325564 [details]
Xorg.0.log from scratch,
 xorg-x11-drv-ati-6.6.3-3.21.el5.x86_64.rpm
Comment 30 PaulB 2008-12-03 12:24:58 EST
Comment on attachment 325564 [details]
Xorg.0.log from scratch,
 xorg-x11-drv-ati-6.6.3-3.21.el5.x86_64.rpm

Dave, 
I installed the scratch rpm and the video was still garbled. I have attached the Xorg.0.log file.
PaulB
Comment 31 Dave Airlie 2008-12-03 18:36:38 EST
Okay one more time, the driver didn't apply the quirks in the right place.

http://porkchop.devel.redhat.com/brewroot/scratch/airlied/task_1597866/

hopefully this one works.
Comment 32 Jeff Burke 2008-12-04 10:35:45 EST
David,
    It is still failing. I will get the Xorg.0.log file and post it to the bz. The behavior is a little different. Now we get no video at all.

    Can you also do me a favor and change the name of your package. Please either increment the number or append a new number. It makes it less confusing when testing.

Thanks,
Jeff
Comment 33 Jeff Burke 2008-12-04 10:51:04 EST
Created attachment 325694 [details]
Xorg.0.log from second scratch build

Using the second scratch build. No video at all.
Comment 34 Dave Airlie 2008-12-05 01:18:22 EST
Okay try again time.

3rd times a charm and all that.

http://porkchop.devel.redhat.com/brewroot/scratch/airlied/task_1600927/

Hopefully this time it will detect a proper VGA monitor and turn it on and put an image on it.
Comment 35 PaulB 2008-12-05 09:47:05 EST
Created attachment 325851 [details]
Xorg.0.log file with  xorg-x11-drv-ati-6.6.3-3.20.el5.da.1.x86_64.rpm

Dave,
Attached is the Xorg.0.log file 
after installing the
xorg-x11-drv-ati-6.6.3-3.20.el5.da.1.x86_64.rpm.

Unfortunately, The result is no video at all.

PaulB
Comment 36 Dave Airlie 2008-12-05 14:46:19 EST
okay at least its no longer detecting the phantom monitor


can you try adding a Modes "1280x1024" in xorg.conf screen section.

or maybe a different monitor to see if produces a signal, that monitor seems to tell lies, which I suspect we need to fix elsewhere.
Comment 37 PaulB 2008-12-05 15:17:32 EST
Dave,
Adding the Modes "1280x1024" in xorg.conf produces clear video.

PaulB
Comment 38 Dave Airlie 2008-12-08 17:29:10 EST
xorg-x11-drv-ati-6.6.3-21.el5 

is built.

can you give that a try.
Comment 40 Russell Doty 2008-12-09 09:10:58 EST
Paul, can you try a different monitor? I'd like to know if this is monitor specific.
Comment 41 PaulB 2008-12-09 14:48:48 EST
Created attachment 326385 [details]
Xorg.0.log file after installing the xorg-x11-drv-ati-6.6.3-3.21.el5.x86_64.rpm.
Comment 42 PaulB 2008-12-09 14:53:18 EST
Dave and Russ D,

Attached is the Xorg.0.log file 
after installing the
xorg-x11-drv-ati-6.6.3-3.21.el5.x86_64.rpm.

Unfortunately, the result is no video at all on the monitor in question.
(see comment #36)
The monitor in question is an Acer model#AL1715.

I attached the system to a Phillips model#170S6FB/27
and the video output is clear.

Notably:
With or without the Modes "1280x1024" line in xorg.conf:
-Acer monitor has no video
-Phillips monitor video output is clear.

-------

Regarding the Acer AL1715:
Another interesting thing.  We moved the xorg.conf file to xorg.conf.bk and
then ran the Display configuration tool and saved what it auto-detected to the
xorg.conf file and rebooted.  Everything worked.  Looking at the diff between
the xorg.conf.bk and xorg.conf files was just a section that described the Acer
Monitor along with its frequency ranges. 

-------

PaulB
Comment 43 Dave Airlie 2008-12-10 03:53:49 EST
Okay it sounds like the Acer might need a quirk for autoconfig to work but hardly a reason to block this. Maybe file another bug against the server for the monitor not auto detecting correctly.
Comment 46 Dave Airlie 2008-12-10 16:39:54 EST
please start a new bug with the monitor and log from it, so we can fix that.

The original bug is fixed. so this bug should be included in the errata and closed when the errata goes out.
Comment 49 errata-xmlrpc 2009-01-20 16:39:18 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0166.html

Note You need to log in before you can comment on or make changes to this bug.