Bug 466999 - UTC specific zone
UTC specific zone
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 21:36 EDT by eric@christensenplace.us
Modified: 2015-05-04 21:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 05:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2008-10-14 21:36:16 EDT
Description of problem: Is it possible to have a "location" for UTC time that doesn't specifically have a location?  Does that even make sense?
Comment 1 Petr Machata 2008-10-15 05:06:55 EDT
If I understand your question correctly, then yes, and that zone is called "UTC".
$ /usr/sbin/zdump -v /usr/share/zoneinfo/UTC 
/usr/share/zoneinfo/UTC  Fri Dec 13 20:45:52 1901 UTC = Fri Dec 13 20:45:52 1901 UTC isdst=0 gmtoff=0
/usr/share/zoneinfo/UTC  Sat Dec 14 20:45:52 1901 UTC = Sat Dec 14 20:45:52 1901 UTC isdst=0 gmtoff=0
/usr/share/zoneinfo/UTC  Mon Jan 18 03:14:07 2038 UTC = Mon Jan 18 03:14:07 2038 UTC isdst=0 gmtoff=0
/usr/share/zoneinfo/UTC  Tue Jan 19 03:14:07 2038 UTC = Tue Jan 19 03:14:07 2038 UTC isdst=0 gmtoff=0

(No DST transitions, offset 0.)

$ date +%T\ %z; TZ=UTC date +%T\ %z
11:03:26 +0200
09:03:26 +0000
Comment 2 eric@christensenplace.us 2008-10-15 06:57:40 EDT
Yes.  BUT when I go into my clock preferences (under GNOME) and use the pulldown for Timezone there isn't a UTC zone.  Is it possible to have that added to the list?  Maybe this is the wrong package?
Comment 3 Petr Machata 2008-10-15 07:49:49 EDT
Dunno what Gnome uses, but in system-config-time, there's a section called "non-geographical time zones".  I can see UTC there.  If you have problems with that, reopen the bug and reassign it to the right package, because the bug is not in tzdata.

Note You need to log in before you can comment on or make changes to this bug.