Bug 467027 - PC hangs after click on "Skip" button in "Installation Number" query.
PC hangs after click on "Skip" button in "Installation Number" query.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
i386 Linux
medium Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 06:19 EDT by Krzysztof Wojcik
Modified: 2009-06-20 03:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 17:50:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda logs (15.91 KB, text/plain)
2008-10-15 10:49 EDT, Krzysztof Wojcik
no flags Details
tty screenshots (295.54 KB, application/x-zip-compressed)
2008-10-20 07:11 EDT, Krzysztof Wojcik
no flags Details
screenshot (64.38 KB, image/jpeg)
2008-11-12 02:58 EST, Krzysztof Wojcik
no flags Details

  None (edit)
Description Krzysztof Wojcik 2008-10-15 06:19:23 EDT
Description of problem:
PC hangs after click on "Skip" button when installer ask for Installation Number. 


Version-Release number of selected component (if applicable):
-OS: RHEL5.3 20081006.0 i386 (32bit) / x86_64 (64 bit))
-Chipset: ICH9
-CRB: Intel DQ35JO


Steps to Reproduce:
1. Choose New Installation. 
2. Use default settings on all pages.
3. Click on Skip button when installer needs Installation Number
  
Actual results:
Hangs comes after click on "Skip" button.

Expected results:
Installer has to go ahead.
Comment 1 Krzysztof Wojcik 2008-10-15 10:49:21 EDT
Created attachment 320444 [details]
Anaconda logs
Comment 2 Chris Lumens 2008-10-15 13:46:03 EDT
What kernel messages do you see on tty4?  I bet something funny is going on with the hard drive scanning.
Comment 3 Krzysztof Wojcik 2008-10-17 03:22:50 EDT
There is no error message.
The last message is „starting graphical installation”.
Comment 4 Hans de Goede 2008-10-17 03:37:02 EDT
Is this the same system on which installing RHEL-5.2 results in a non booting system (it just says GRUB and then stops?), IOW is this the same system as the one in bug 462854 ?

Note to clumens, it probably is (same motherboard, same reporter), if it is note 2 things:
1) This system is using dmraid!
2) Its go an interesting HD setup, from the syslog from bug 462854 ? :

ata1.00: ATA-7: WDC WD2500YS-01SHB1, 20.06C06, max UDMA/133
ata2.00: ATA-7: WDC WD2500YS-01SHB1, 20.06C06, max UDMA/133
scsi7 : pata_marvell
ata7.00: ATA-7: ST3160815A, 3.AAD, max UDMA/100

So this system has 2 sata disks on the ich9 and then a pata disk on a marvel
controller which gets detected as the last disk, which might confuse things.
Comment 5 Krzysztof Wojcik 2008-10-17 11:17:56 EDT
Hans,

Thank you for your help.
We tested a few cases and we have new information.
- If we try install OS on single SATA disk (PATA disk disconnected) we get successful result.
- If we install OS on raid (raid on SATA disks, PATA disconnected) we get the same issue- system hangs after click on "Skip" button.

In this situation we can not assemble system as we need (6 SATA disk for raid and 1 disk for OS). 

Do you have any idea, why we have problem with PATA disks?
Why the same issue is on SATA raid?

I think this Bugzilla record is similar to bug 462854 but not exactly.
I both cases we use the same PCs.
Comment 6 Hans de Goede 2008-10-17 19:39:49 EDT
2 questions:

1) What happens when you do a single SATA disk install with the pata disk present?
2) Can you please check all tty's (you can switch with CTRL+ALT+F1 / F2 / F3, etc.
   For any possibly related messages, esp. messages about harddisk / raid 
   detection?
Comment 7 Krzysztof Wojcik 2008-10-20 07:09:10 EDT
(In reply to comment #6)

> 1) What happens when you do a single SATA disk install with the pata disk
> present?

This problem occurs only if Raid is configured. Without raid configuration installation don’t hangs. It was checked with/without pata disk and with different number of sata disks

> 2) Can you please check all tty's (you can switch with CTRL+ALT+F1 / F2 / F3,
> etc.
>    For any possibly related messages, esp. messages about harddisk / raid 
>    detection?

Screenshots in attachment.
Comment 8 Krzysztof Wojcik 2008-10-20 07:11:23 EDT
Created attachment 320861 [details]
tty screenshots
Comment 9 Hans de Goede 2008-10-20 08:18:13 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > 2) Can you please check all tty's (you can switch with CTRL+ALT+F1 / F2 / F3,
> > etc.
> >    For any possibly related messages, esp. messages about harddisk / raid 
> >    detection?
> 
> Screenshots in attachment.

Thanks!

It looks like you've got 2 different issues here:

1) The hang you are seeing is most likely a bug in the RHEL-5.3 nightly build you are using. Please try again with the latest nightly build: RHEL5.3 20081018.0 or later.

2) One of the message in screenshot 4.JPG looks really bad:
"Unrecoverable read error - auto reallocate failed"

This usually means your disk (sda in this case) is really broken and needs to be replaced. It is very unlikely (almost impossible) that this is caused by the dmraid issues and most likely that that disk is really broken, so please replace it.
Comment 10 Krzysztof Wojcik 2008-10-21 02:53:25 EDT
(In reply to comment #9)

> It looks like you've got 2 different issues here:
> 
> 1) The hang you are seeing is most likely a bug in the RHEL-5.3 nightly build
> you are using. Please try again with the latest nightly build: RHEL5.3
> 20081018.0 or later.

We do not know about new build of RHEL5.3.
Where from we can download it?


> 2) One of the message in screenshot 4.JPG looks really bad:
> "Unrecoverable read error - auto reallocate failed"
> 
> This usually means your disk (sda in this case) is really broken and needs to
> be replaced. It is very unlikely (almost impossible) that this is caused by the
> dmraid issues and most likely that that disk is really broken, so please
> replace it.

We will check it.
Comment 11 Hans de Goede 2008-10-21 07:10:58 EDT
(In reply to comment #10)
> (In reply to comment #9)
> 
> > It looks like you've got 2 different issues here:
> > 
> > 1) The hang you are seeing is most likely a bug in the RHEL-5.3 nightly build
> > you are using. Please try again with the latest nightly build: RHEL5.3
> > 20081018.0 or later.
> 
> We do not know about new build of RHEL5.3.
> Where from we can download it?
> 

I will talk with RH's partnermanager for Intel and see what I can do. In the mean time can you please try the snapshot you do have with an update disk containing the fix for this issue?

When you boot the installer press tab at the first screen, and then enter the following at the end of the cmdline you get (preceded by a space):
updates=http://jgranado.fedorapeople.org/temp/pyblock.img

Thanks!
Comment 12 Krzysztof Wojcik 2008-10-21 07:48:48 EDT
(In reply to comment #9)


> It looks like you've got 2 different issues here:
> 
> 1) The hang you are seeing is most likely a bug in the RHEL-5.3 nightly build
> you are using. Please try again with the latest nightly build: RHEL5.3
> 20081018.0 or later.
> 
> 2) One of the message in screenshot 4.JPG looks really bad:
> "Unrecoverable read error - auto reallocate failed"
> 
> This usually means your disk (sda in this case) is really broken and needs to
> be replaced. It is very unlikely (almost impossible) that this is caused by the
> dmraid issues and most likely that that disk is really broken, so please
> replace it.

We checked it. This is not reason for our issue. We replaced disk and also whole PC and behavior is still wrong. 
However we observed that problem is only on RADD0.
Summary:
- RAID0 - kernel panic after restart
- RAID1 - ok
- RAID5 - errors during installation preparing (error opening /dev/mapper/isw_bcdjijeehd_TEST5: no such device or address)
- RAID10 – bootloader does not start after reboot

We will report new bug for this issue.
Comment 13 Hans de Goede 2008-10-21 08:06:11 EDT
(In reply to comment #12)
> Summary:
> - RAID0 - kernel panic after restart
> - RAID1 - ok
> - RAID5 - errors during installation preparing (error opening
> /dev/mapper/isw_bcdjijeehd_TEST5: no such device or address)
> - RAID10 – bootloader does not start after reboot
> 

Which with version of RHEL *exactly* did you do these tests and did you use the updates URL I provided?
Comment 14 Krzysztof Wojcik 2008-10-21 11:11:12 EDT
(In reply to comment #13)

> Which with version of RHEL *exactly* did you do these tests and did you use the
> updates URL I provided?

We use RHEL5.3 Alpha1 - "RHEL5.3-Server-20081006.0-i386-DVD.iso"

Now we are trying to install RHEL according to your procedure described in comment 11.
I will inform you if we finish.
Comment 15 Chris Lumens 2008-10-22 11:16:00 EDT
After you replaced the disk, do you still get the same error messages as shown in 4.JPG?
Comment 16 Denise Dumas 2008-10-27 14:29:57 EDT
Krzysztof, any update on this problem?
Comment 17 RHEL Product and Program Management 2008-10-30 12:22:35 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 21 Ronald Pacheco 2008-11-05 08:19:16 EST
Intel,

We need a response to Commnet #15, or we will have to move this to RHEL 5.4 since we only have one snapshot left to clean up feature requests.
Comment 22 Krzysztof Wojcik 2008-11-06 03:57:57 EST
See comment 12.
We replaced disk and PC also. We still get the message as shown in 4.jpg.
Comment 23 Hans de Goede 2008-11-06 04:07:28 EST
(In reply to comment #22)
> See comment 12.
> We replaced disk and PC also. We still get the message as shown in 4.jpg.

Krzysztof, can you please retest with the RHEL5.3 beta release, with that version isw raid installations should work.
Comment 24 Joel Andres Granados 2008-11-10 03:46:12 EST
Ping:

any update?

The changes contained in comment 11s update image are already in anaconda.  If you test with the current beta you should be ok when using raid.
Comment 25 Krzysztof Wojcik 2008-11-12 02:56:07 EST
We tested installation of RHEL5.3 beta on raids and we found two bugs:

1. Bootloader don't start after RH 5.3 Beta installation on RAID0

Steps to reproduce:
1. Create RAID0 in OROM. Use default settings.
2. Boot RH from DVD
3. Choose New Installation. Use default settings on all pages. 
4. On Suggested Partitioning page use configured RAID for installation and bootloader.

Expected results:
After installation restart, bootloader start automatically 

Actual results:
Bootloader don't start. 


2. RH 5.3 Beta does not support RAID1 volumes.

Steps to reproduce:
1. Create RAID1 in OROM. Use default settings.
2. Boot RH from DVD
3. Choose New Installation Use default settings on all pages. 
4. There will be error with message "Error opening dev/mapper/ ... (look at attachmnent)


Environment Details:
-OS: RHEL5.3-Server-20081020.1-i386-DVD.iso
-Chipset: ICH9
Comment 26 Krzysztof Wojcik 2008-11-12 02:58:37 EST
Created attachment 323300 [details]
screenshot
Comment 27 Joel Andres Granados 2008-11-13 09:42:09 EST
krzysztof Wojcik:
Thank you for you feedback.

In comment #11 an update image was given.  This is related to a change that was mad to pyblock to make the new isw raid work.  All my tests on Oct 17 told me that this was solved.  My test consisted on installing on a system with RAID0 ISW and making sure that the anaconda partitioning screen correctly showed me the raid sets (which it still does).  This is consistent with what you saw in comment #12.

When I do an install with a tree from 2008-11-12 with RAID1 it blows up. I followed the error to device-mapper.  If you have a RHEL5.3 installed and run `dmraid -ay` on a RAID1 you will get an error that no devices was created.  When anaconda sees this it just continues believing that there are no raid devices in the system (which is what we want to do).

I think this issue is due to the new fixes that went into device-mapper in september.

FYI you can reproduce this by changing to tty2 in installation and running `dmraid -ay`.  The error messages will appear in tty4.  the messages are:
"
device-mapper: table: 253:0: mirror: Wrong number of mirror arguments
device-mapper: ioctl: error adding target to table.
"

This addresses the RAID1 part of the problem, but not the RAID5.
Comment 28 Joel Andres Granados 2008-11-13 10:01:15 EST
Bug 471400 now tracks the device-mapper issue now.
Comment 29 Hans de Goede 2008-11-17 17:50:15 EST
The mentioned raid1 issue is solved in snapshot3, raid5 not working is a known problem which is being tracked in bug 437184, as the initial problem reported in the report now is solved I'm closing it.
Comment 30 Joel Andres Granados 2008-11-18 05:49:19 EST
(In reply to comment #27)
> krzysztof Wojcik:
> Thank you for you feedback.
> 
.
.
.
> "
> device-mapper: table: 253:0: mirror: Wrong number of mirror arguments
> device-mapper: ioctl: error adding target to table.
> "
> 
> This addresses the RAID1 part of the problem, but not the RAID5.

There is no current issue with RAID5.  According to comment  #25 (last comment from reporter).  I have tested installations with RAID1 and RAID0 and everything works as expected.

Note You need to log in before you can comment on or make changes to this bug.