Bug 467056 - Unable to build any spu binary with spu-binutils
Unable to build any spu binary with spu-binutils
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spu-binutils (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Jochen Roth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 10:21 EDT by Jochen Roth
Modified: 2009-02-10 13:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 13:14:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to include binutils needed by spu-gcc (2.22 KB, patch)
2008-10-16 06:56 EDT, Jochen Roth
no flags Details | Diff

  None (edit)
Description Jochen Roth 2008-10-15 10:21:25 EDT
Description of problem:

After installation of spu-binutils-2.18.50.0.9-6 the following messages appear while trying to build a spu binary:


/tmp/ccRJ9Qgb.s:370: Error: Unrecognized opcode: `lqd'

/tmp/ccRJ9Qgb.s:371: Error: Unrecognized opcode: `lqd'

/tmp/ccRJ9Qgb.s:373: Error: Unrecognized opcode: `bi'

/tmp/ccRJ9Qgb.s:379: Error: Unrecognized opcode: `ila'

/tmp/ccRJ9Qgb.s:380: Error: Unrecognized opcode: `stqd'

/tmp/ccRJ9Qgb.s:381: Error: Unrecognized opcode: `hbrr'

/tmp/ccRJ9Qgb.s:382: Error: Unrecognized opcode: `stqd'

/tmp/ccRJ9Qgb.s:383: Error: Unrecognized opcode: `stqd'

/tmp/ccRJ9Qgb.s:384: Error: Unrecognized opcode: `ai'

/tmp/ccRJ9Qgb.s:385: Error: Unrecognized opcode: `lqd'

/tmp/ccRJ9Qgb.s:386: Error: Unrecognized opcode: `cdd'

/tmp/ccRJ9Qgb.s:387: Error: Unrecognized opcode: `lqd'

/tmp/ccRJ9Qgb.s:388: Error: Unrecognized opcode: `shufb'

.....
Comment 1 Jochen Roth 2008-10-16 03:50:37 EDT
The problem is that spu-binutils doesn't install the assembler in /usr/spu/bin where spu-gcc expects him to be. 

spu-gcc is searching in the following directory[1] for as. He uses the default assembler installed in /usr/bin/as if he doesn't find the target specific as. 
The default assembler on a ppc64 machine is the assembler installed by the system binutils.ppc64 package.

[1]
stat("/usr/lib/gcc/spu/4.1.1/../../../../spu/bin/as", 0xffe07de0) = -1 ENOENT (No such file or directory)
Comment 2 Jochen Roth 2008-10-16 04:00:34 EDT
A patch which solves this problem is in progress.
Comment 3 Jochen Roth 2008-10-16 06:56:09 EDT
Created attachment 320541 [details]
patch to include binutils needed by spu-gcc

Hi Jan, can you please have a look at this patch? Thanks!
Comment 4 Jochen Roth 2008-10-20 04:59:45 EDT
spu-binutils-2.18.50.0.9-7.fc10 is now in rawhide.
Comment 5 Bug Zapper 2008-11-25 22:53:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.