Bug 467060 - Rawhide kernel 2.6.27-3 hangs when booting with a notebook with ATI RS485 chipset
Rawhide kernel 2.6.27-3 hangs when booting with a notebook with ATI RS485 chi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 10:47 EDT by Mauro Carvalho Chehab
Modified: 2013-07-04 18:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 10:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf used on tests (1.30 KB, text/plain)
2009-02-06 04:56 EST, Mauro Carvalho Chehab
no flags Details
Xorg.0.log (118.14 KB, text/plain)
2009-02-06 05:08 EST, Mauro Carvalho Chehab
no flags Details
/var/log/messages (43.48 KB, text/plain)
2009-02-06 08:01 EST, Mauro Carvalho Chehab
no flags Details
/var/log/dmesg (26.89 KB, text/plain)
2009-02-06 08:04 EST, Mauro Carvalho Chehab
no flags Details

  None (edit)
Description Mauro Carvalho Chehab 2008-10-15 10:47:26 EDT
Description of problem:

Rawhide with upstream vanilla kernel 2.6.23 boots fine and graphics work. However, when booting with kernel 2.6.27-3-fc.i386, when radeon module is probed, the screen became blank or with bold vertical lines and machine hangs.

To avoid an immediate hang, I've used the following steps:

1) booted kernel with "nomodeset 3"
2) redirected console with netconsole;
3) removed modules with:
    rmmod radeon drm
4) inserted drm modules with
    insmod drm debug=1
    insmod radeon

and machine hanged.

I was expecting a kernel panic dump, but no panic went to netconsole. All I got are those debug messages:

Oct 15 12:23:12 gaivota [drm] Initialized drm 1.1.0 20060810
Oct 15 12:23:12 gaivota [drm] Initialized drm 1.1.0 20060810
Oct 15 12:23:18 gaivota [drm: drm_init] 
Oct 15 12:23:18 gaivota [drm: drm_init] 
Oct 15 12:23:18 gaivota [drm: drm_get_dev] 
Oct 15 12:23:18 gaivota [drm: drm_get_dev] 
Oct 15 12:23:18 gaivota [drm: drm_get_minor] 
Oct 15 12:23:18 gaivota [drm: drm_get_minor] 
Oct 15 12:23:18 gaivota [drm: drm_get_minor] new minor assigned 64
Oct 15 12:23:18 gaivota [drm: drm_get_minor] new minor assigned 64
Oct 15 12:23:18 gaivota [drm: drm_get_minor] 
Oct 15 12:23:18 gaivota [drm: drm_get_minor] 
Oct 15 12:23:18 gaivota [drm: drm_get_minor] new minor assigned 0
Oct 15 12:23:18 gaivota [drm: drm_get_minor] new minor assigned 0
Oct 15 12:23:18 gaivota [drm: radeon_driver_load] PCI card detected
Oct 15 12:23:18 gaivota [drm: radeon_driver_load] PCI card detected
Oct 15 12:23:18 gaivota [drm: drm_addmap_core] offset = 0xb0100000, size = 0x00010000, type = 1
Oct 15 12:23:18 gaivota [drm: drm_addmap_core] offset = 0xb0100000, size = 0x00010000, type = 1
Oct 15 12:23:18 gaivota [drm: radeon_get_bios] COMBIOS detected
Oct 15 12:23:18 gaivota [drm: radeon_get_bios] COMBIOS detected
Oct 15 12:23:18 gaivota [drm: radeon_get_vram_type] RAM width 128 bits DDR
Oct 15 12:23:18 gaivota [drm: radeon_get_vram_type] RAM width 128 bits DDR

I also tried to get something with kdump, but no kernel dump were generated at the remote machine.

The notebook is Gateway MX6453

The PCI ID of the graphics adapter is 1002:5975, subsystem ID: 107b:0367
Comment 1 Mauro Carvalho Chehab 2008-10-15 17:00:52 EDT
David Airlie suggested to start radeon.dynclks=0.

With this parameter, machine booted ok, and X started. After login, gnome loaded, but X hanged. The machine kept alive.

I've manually killed Xorg. this caused those errors:


[drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
[drm:radeon_cs_ioctl] *ERROR* ib_get failed
[drm:radeon_mem_init_heap] *ERROR* heap already initialized?
mtrr: base(0xca183000) is not aligned on a size(0xbdc000) boundary
[drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
[drm:radeon_cs_ioctl] *ERROR* ib_get failed
[drm:radeon_mem_init_heap] *ERROR* heap already initialized?
mtrr: base(0xcc55a000) is not aligned on a size(0xbdc000) boundary
[drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
[drm:radeon_cs_ioctl] *ERROR* ib_get failed
[drm:radeon_mem_init_heap] *ERROR* heap already initialized?
mtrr: base(0xce939000) is not aligned on a size(0xbdc000) boundary
[drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
[drm:radeon_cs_ioctl] *ERROR* ib_get failed
[drm:drm_buffer_object_validate] *ERROR* Failed moving buffer.
[drm:drm_buffer_object_validate] *ERROR* Out of aperture space or DRM memory quota.
[drm:radeon_mem_init_heap] *ERROR* heap already initialized?
mtrr: base(0xc3ff1000) is not aligned on a size(0xbdc000) boundary
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id


After some time, and another kill at Xorg, machine got an OOPS:

------------[ cut here ]------------
kernel BUG at drivers/gpu/drm/drm_gem.c:379!
invalid opcode: 0000 [#1] SMP 
Modules linked in: vfat fat ipt_MASQUERADE iptable_nat nf_nat sco bridge stp bnep l2cap bluetooth ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi fuse sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand powernow_k8 dm_multipath kvm_amd kvm rtl8187 eeprom_93cx6 joydev snd_hda_intel video snd_seq_dummy firewire_ohci output firewire_core yenta_socket crc_itu_t rsrc_nonstatic tifm_7xx1 snd_seq_oss sky2 tifm_core snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_hwdep k8temp snd soundcore hwmon pcspkr i2c_piix4 option usbserial pata_acpi ata_generic pata_atiixp radeon drm i2c_algo_bit i2c_core

Pid: 4345, comm: Xorg Not tainted (2.6.27-3.fc10.i686 #1)
EIP: 0060:[<f886e5de>] EFLAGS: 00213246 CPU: 0
EIP is at drm_gem_object_free+0x15/0x51 [drm]
EAX: f43170c0 EBX: f7862800 ECX: c1e0bab4 EDX: 00000000
ESI: f43170c0 EDI: 00000001 EBP: f5039d30 ESP: f5039d28
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process Xorg (pid: 4345, ti=f5039000 task=f4f36600 task.ti=f5039000)
Stack: f43170c0 f886e5c9 f5039d40 c0527fe5 f43170c0 f43170c0 f5039d4c f886e5b3 
       00000000 f5039d54 f886e5c5 f5039d94 c0526891 00000000 f886e5b6 00000020 
       f5039d70 f43335f0 f786280c f5039d7c c041ec7a f5039d84 c06d990a f5039d94 
Call Trace:
 [<f886e5c9>] ? drm_gem_object_free+0x0/0x51 [drm]
 [<c0527fe5>] ? kref_put+0x39/0x44
 [<f886e5b3>] ? drm_gem_object_handle_unreference+0x28/0x2b [drm]
 [<f886e5c5>] ? drm_gem_object_release_handle+0xf/0x13 [drm]
 [<c0526891>] ? idr_for_each+0x60/0x99
 [<f886e5b6>] ? drm_gem_object_release_handle+0x0/0x13 [drm]
 [<c041ec7a>] ? need_resched+0x18/0x22
 [<c06d990a>] ? _cond_resched+0x8/0x32
 [<f886e643>] ? drm_gem_release+0x29/0x3b [drm]
 [<f886de1b>] ? drm_release+0x200/0x3a6 [drm]
 [<c04973bc>] ? __fput+0xb2/0x142
 [<c0497468>] ? fput+0x1c/0x1e
 [<c0494b85>] ? filp_close+0x55/0x5f
 [<c042e99b>] ? put_files_struct+0x6d/0xaf
 [<c042ea1a>] ? exit_files+0x3d/0x42
 [<c04300c7>] ? do_exit+0x1ea/0x749
 [<c04369a7>] ? __sigqueue_free+0x32/0x35
 [<c043069b>] ? do_group_exit+0x75/0x9c
 [<c0438f3e>] ? get_signal_to_deliver+0x2b4/0x2db
 [<c0403f97>] ? do_notify_resume+0x76/0x67e
 [<c0437920>] ? send_signal+0x200/0x216
 [<c0437a13>] ? do_tkill+0xdd/0xef
 [<c04aa2db>] ? mntput_no_expire+0x1f/0xfc
 [<c0497444>] ? __fput+0x13a/0x142
 [<c0462a7a>] ? audit_syscall_entry+0xfe/0x128
 [<c0462967>] ? audit_syscall_exit+0xb7/0xcc
 [<c0404e1d>] ? work_notifysig+0x13/0x1a
 =======================
Code: 5b 5d c3 55 89 e5 66 66 90 66 90 89 d0 e8 c6 ff ff ff 31 c0 5d c3 55 89 e5 56 53 66 66 90 66 90 8b 58 08 89 c6 83 7b 0c 01 75 04 <0f> 0b eb fe 8b 83 9c 02 00 00 8b 90 90 00 00 00 85 d2 74 04 89 
EIP: [<f886e5de>] drm_gem_object_free+0x15/0x51 [drm] SS:ESP 0068:f5039d28
---[ end trace 8ae7ef10ca93bfb5 ]---
Fixing recursive fault but reboot is needed!
Comment 2 Mauro Carvalho Chehab 2008-10-15 17:01:59 EDT
(In reply to comment #1)
> David Airlie suggested to start radeon.dynclks=0.

I mean Dave Airlie. sorry for the typo.
Comment 3 Dave Airlie 2008-10-16 05:16:54 EDT
can you try the latest kernel and -ati driver from koji please.

I got an rs485 laptop for a few hours to play with and it worked for me once I fixed a few issues..
Comment 4 James Laska 2008-10-16 10:02:34 EDT
Same here ...

Packages tested:
 * kernel-2.6.27-13.fc10.i686
 * xorg-x11-drv-ati-6.9.0-27.fc10.i386
 * xorg-x11-server-Xorg-1.5.2-4.fc10.i386

* Smolt profile - http://www.smolts.org/client/show/pub_9ed1d230-39f5-4080-80b2-5cfba5bfb24e

Installed and trying kernel-2.6.27-17.fc10 ...
Comment 5 James Laska 2008-10-16 10:36:59 EDT
I haven't yet trigged the kernel call trace ... but still seeing the same `dmesg` output when testing:

 * kernel-2.6.27-13.fc10.i686
 * xorg-x11-drv-ati-6.9.0-27.fc10.i386
 * xorg-x11-server-Xorg-1.5.2-4.fc10.i386

Against smolt system: http://www.smolts.org/client/show/pub_9ed1d230-39f5-4080-80b2-5cfba5bfb24e

[drm] DAC-6: set mode 1400x1050 18
fuse init (API version 7.9)
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[drm] LVDS-8: set mode  12
[drm] bios LVDS_GEN_CNTL: 0xff24
[drm] DAC-6: set mode 1680x1050 14
[drm:radeon_mem_init_heap] *ERROR* heap already initialized?
mtrr: base(0xc3d20000) is not aligned on a size(0xac5000) boundary
[drm] DAC-6: set mode 1400x1050 1a
Comment 6 Mauro Carvalho Chehab 2008-10-16 14:10:45 EDT
With the above packages, the situation is better, but there are still some troubles:

1) during boot, without rhgb, instead of a Tux logo, a blank box appears at the top right corner for some seconds. With rhgb, instead of Tux, a random image that looks like white noise is presented;

2) during gnome initialization,Xorg hangs (screen keeps the last seen image - both keyboard types and mouse movements don't change anything). The machine keeps working, and no errors are printed at dmesg.

3) if I kill Xorg proccess, I get this log when Xorg restarts:

[drm:radeon_mem_init_heap] *ERROR* heap already initialized?
mtrr: base(0xc2807000) is not aligned on a size(0xbdc000) boundary

4) KDE starts without troubles, but sometimes, it also hangs.

5) Sometimes, when killing Xorg, I got this error:

[drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
[drm:radeon_cs_ioctl] *ERROR* ib_get failed

6) 3D (tested with glxinfo/glxgears) seems to work properly
Comment 7 Dave Airlie 2008-10-16 17:30:39 EDT
the hang at bootup is some other component, do a full rawhide upgrade, and regenerate initrd. either plymouth or initscripts is old.

heap init message can be ignored.. I need to remove that.

the other bits I'll attempt to figure out
Comment 8 Chris 2008-10-21 12:55:52 EDT
I also had this problem. The radeon driver would cause the system to randomly lock up, sometimes at the end of the boot, sometimes when the login screen was presented. I'm running a Mobility Radeon 9700. The vesa driver worked fine.
I just upgraded to kernel-2.6.27.3-34.rc1.fc10 and xorg-x11-drv-ati-6.9.0-29.fc10 from koji. Now everything is working fine, even DRI. Thanks for the excellent work.
Comment 9 Mauro Carvalho Chehab 2008-10-24 06:19:10 EDT
New tests after a rawhide upgrade. Machine is now using those userspace packages:
xorg-x11-drv-ati-6.9.0-29.fc10.i386 and xorg-x11-server-Xorg-1.5.2-8.fc10.i386

It is now with kernel-2.6.27.3-34.rc1.fc10.i686.

With this configuration, X doesn't work. Machine boots fine, until X start.

1) with nomodeset: When X starts, a black screen is shown (it seems that even the LCD backlight is turned off);

2) removing nomodeset: Fedora graphical background is showed during boot. However, when X starts, screen also become black.

Those are the drm related dmesg messages with 2.6.7.3-34 (without drm debug enabled):

Oct 24 07:46:44 gaivota kernel: [drm] Detected VRAM RAM=262144K, accessible=262144K, BAR=262144K
Oct 24 07:46:44 gaivota kernel: [drm] Default TV standard: NTSC
Oct 24 07:46:44 gaivota kernel: [drm] 14.318180000 MHz TV ref clk
Oct 24 07:46:44 gaivota kernel: [drm] Panel ID String: SEC
Oct 24 07:46:44 gaivota kernel: [drm] Panel Size 1280x800
Oct 24 07:46:44 gaivota kernel: [drm] LVDS-8: set mode 1280x800 a
Oct 24 07:46:44 gaivota kernel: [drm] bios LVDS_GEN_CNTL: 0x30ff20
Oct 24 07:46:44 gaivota kernel: fb0: radeondrmfb frame buffer device
Oct 24 07:46:44 gaivota kernel: registered panic notifier
Oct 24 07:46:44 gaivota kernel: [drm] Loading R300 Microcode
Oct 24 07:46:44 gaivota kernel: [drm] Num pipes: 3
Oct 24 07:46:44 gaivota kernel: [drm] writeback test failed
Oct 24 07:46:44 gaivota kernel: [drm] Initialized radeon 1.29.0 20080528 on minor 0

I tested against the latest kernel I have here before -34:

With kernel kernel-2.6.27.3-30.rc1.fc10.i686 and nomodeset, everything works fine. 

Please let me know if you want me to turn debug on or need any new tests.
Comment 10 Bug Zapper 2008-11-25 22:53:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 François Cami 2009-02-04 03:03:53 EST
Mauro,
Does the problem still manifest itself in current F10 ?
If yes, could you try the latest xorg-x11-drv-ati in Koji :
http://koji.fedoraproject.org/koji/buildinfo?buildID=80819
and please post /var/log/Xorg.0.log as uncompressed text attachment to this bug.
As per comment #9 it looks like a KMS problem.
Comment 12 Mauro Carvalho Chehab 2009-02-05 13:39:25 EST
Tested with Koji x11 ati driver + kernel 2.6.27.12-170.2.5. Still not ok:

without nomodeset (the default), monitor connected before boot:

- The rhgb graphics screen appears on a high resolution (maybe 1280x800?), but the fedora logo appears at a lower resolution.
- After boot, when X starts, both internal and external monitors show the same picture, at 800x600. xrandr doesn't work fine: I couldn't disable mirror mode, and it didn't set the proper resolutions. If LVDS is disabled with xrandr, it can't be enabled again.

without nomodeset, monitor connected after X starts:
- The external monitor starts disabled. A call to xrandr can enable it. Yet, xrandr can't put a different image at the second monitor;

with nomodeset:
- everything seems to work properly.

The tux logo (without nomodeset) is showed as a random image.
Comment 13 François Cami 2009-02-05 18:17:06 EST
Mauro,
Thanks for the additional information.
Could you try using a Virtual line with KMS enabled, like :
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Virtual 3200 1200
        EndSubSection
There is a known bug in KMS drivers not setting a virtual size correctly.
Could you attach /var/log/Xorg.0.log and dmesg as uncompressed text files too ?
ASSIGNED to xorg-x11-drv-ati .
Comment 14 Mauro Carvalho Chehab 2009-02-06 04:56:46 EST
Created attachment 331106 [details]
xorg.conf used on tests

Still didn't work. This is the xorg.conf I'm currently using. I'll attach the logs and some additional info on the next comment.
Comment 15 Mauro Carvalho Chehab 2009-02-06 05:08:33 EST
Created attachment 331108 [details]
Xorg.0.log

I did the tests without nomodeset option, external monitor connected after X starts.

As expected, the external monitor started disabled.

The monitor were successfully enabled by:
$ xrandr --output VGA-0 --auto

However this command still fails:
xrandr --output VGA-0 --auto --right-of LVDS

While checking for logs, I noticed those errors at the dmesg:


[drm:edid_is_valid] *ERROR* EDID has minor version 4, which is not between 0-3  
[drm:edid_is_valid] *ERROR* Raw EDID:                                           
<3>00 ff ff ff ff ff ff 00 10 ac 16 d0 48 4c 46 34  ............HLF4            
<3>1a 12 01 04 6a 25 17 78 ef b6 90 a6 54 51 91 25  ....j%.x....TQ.%            
<3>17 50 54 a5 4b 00 81 80 71 4f 95 00 01 01 01 01  .PT.K...qO......            
<3>01 01 01 01 01 01 ab 22 a0 a0 50 84 1a 30 30 20  ......."..P..00             
<3>36 00 72 e6 10 00 00 1a 00 00 00 ff 00 47 33 34  6.r..........G34            
<3>30 48 38 36 50 34 46 4c 48 0a 00 00 00 fd 00 32  0H86P4FLH......2            
<3>4d 1e 53 0e 04 11 b2 05 f8 58 f0 00 00 00 00 fc  M.S......X......            
<3>00 44 45 4c 4c 20 45 31 37 38 57 46 50 0a 00 78  .DELL E178WFP..x            

pci 0000:01:05.0: VGA-1: EDID invalid.
[drm:edid_is_valid] *ERROR* EDID has minor version 4, which is not between 0-3
[drm:edid_is_valid] *ERROR* Raw EDID:                                         
<3>00 ff ff ff ff ff ff 00 10 ac 16 d0 48 4c 46 34  ............HLF4          
<3>1a 12 01 04 6a 25 17 78 ef b6 90 a6 54 51 91 25  ....j%.x....TQ.%          
<3>17 50 54 a5 4b 00 81 80 71 4f 95 00 01 01 01 01  .PT.K...qO......          
<3>01 01 01 01 01 01 ab 22 a0 a0 50 84 1a 30 30 20  ......."..P..00           
<3>36 00 72 e6 10 00 00 1a 00 00 00 ff 00 47 33 34  6.r..........G34          
<3>30 48 38 36 50 34 46 4c 48 0a 00 00 00 fd 00 32  0H86P4FLH......2          
<3>4d 1e 53 0e 04 11 b2 05 f8 58 f0 00 00 00 00 fc  M.S......X......
<3>00 44 45 4c 4c 20 45 31 37 38 57 46 50 0a 00 78  .DELL E178WFP..x

pci 0000:01:05.0: VGA-1: EDID invalid.
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm] DAC-6: set mode  f
[drm:edid_is_valid] *ERROR* EDID has minor version 4, which is not between 0-3
[drm:edid_is_valid] *ERROR* Raw EDID:
<3>00 ff ff ff ff ff ff 00 10 ac 16 d0 48 4c 46 34  ............HLF4
<3>1a 12 01 04 6a 25 17 78 ef b6 90 a6 54 51 91 25  ....j%.x....TQ.%
<3>17 50 54 a5 4b 00 81 80 71 4f 95 00 01 01 01 01  .PT.K...qO......
<3>01 01 01 01 01 01 ab 22 a0 a0 50 84 1a 30 30 20  ......."..P..00
<3>36 00 72 e6 10 00 00 1a 00 00 00 ff 00 47 33 34  6.r..........G34
<3>30 48 38 36 50 34 46 4c 48 0a 00 00 00 fd 00 32  0H86P4FLH......2
<3>4d 1e 53 0e 04 11 b2 05 f8 58 f0 00 00 00 00 fc  M.S......X......
<3>00 44 45 4c 4c 20 45 31 37 38 57 46 50 0a 00 78  .DELL E178WFP..x

pci 0000:01:05.0: VGA-1: EDID invalid.
[drm:edid_is_valid] *ERROR* EDID has minor version 4, which is not between 0-3
[drm:edid_is_valid] *ERROR* Raw EDID:
<3>00 ff ff ff ff ff ff 00 10 ac 16 d0 48 4c 46 34  ............HLF4
<3>1a 12 01 04 6a 25 17 78 ef b6 90 a6 54 51 91 25  ....j%.x....TQ.%
<3>17 50 54 a5 4b 00 81 80 71 4f 95 00 01 01 01 01  .PT.K...qO......
<3>01 01 01 01 01 01 ab 22 a0 a0 50 84 1a 30 30 20  ......."..P..00
<3>36 00 72 e6 10 00 00 1a 00 00 00 ff 00 47 33 34  6.r..........G34
<3>30 48 38 36 50 34 46 4c 48 0a 00 00 00 fd 00 32  0H86P4FLH......2
<3>4d 1e 53 0e 04 11 b2 05 f8 58 f0 00 00 00 00 fc  M.S......X......
<3>00 44 45 4c 4c 20 45 31 37 38 57 46 50 0a 00 78  .DELL E178WFP..x

pci 0000:01:05.0: VGA-1: EDID invalid.
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id

One thing very weird on the above message is that it is claiming that the VGA is VGA-1, instead of VGA-0, as reported by xrandr:

$ xrandr
Screen 0: minimum 320 x 200, current 2080 x 800, maximum 3200 x 1200
VGA-0 connected 800x600+1280+0 (normal left inverted right x axis y axis) 0mm x0mm
   800x600        60.3*
   640x480        59.9
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+
   1024x768       60.0
   800x600        60.3
   640x480        59.9

Another issue here is that it is not using the proper max values for the external monitor, probably due to the lack of decoding the EDAC info.
Comment 16 Matěj Cepl 2009-02-06 07:36:26 EST
Could we get please /var/log/messages and /var/log/dmesg as well?

Thank you
Comment 17 Mauro Carvalho Chehab 2009-02-06 08:01:19 EST
Created attachment 331122 [details]
/var/log/messages

Follows the sanitized /var/log/messages. I think all info at dmesg is inside
this log.
Comment 18 Mauro Carvalho Chehab 2009-02-06 08:04:55 EST
Created attachment 331123 [details]
/var/log/dmesg
Comment 19 Jérôme Glisse 2009-10-13 11:22:19 EDT
Fedora 12 as an improved support for radeon hw can you try a beta livecd and report. Thanks.
Comment 20 James Laska 2009-10-13 13:55:59 EDT
I've been running with rawhide for some time now on the same hardware reported back in comment#4 and am not experiencing this problem.

 * xorg-x11-server-Xorg-1.7.0-1.fc12.i686
 * xorg-x11-drv-ati-6.13.0-0.7.20091006git457646d73.fc12.i686
 * kernel-2.6.31.1-56.fc12.i686
Comment 21 Jérôme Glisse 2009-10-14 10:55:25 EDT
Mauro i am pretty confident that RS480 work with Fedora 12 (like it does for James), only know bug is that suspend/resume is broken but there is already a bug opened for that. So i am closing this bug, reopen if you still have this issue with fedora 12.

Note You need to log in before you can comment on or make changes to this bug.