Bug 467070 - Revise external bugzilla references to use database if local bug id and to use 3.X XMLRPC API
Revise external bugzilla references to use database if local bug id and to us...
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 11:48 EDT by David Lawrence
Modified: 2014-10-12 18:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-20 06:43:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2008-10-15 11:48:59 EDT
Description of problem:
Currently the external bugzilla code uses the non-standard RH Bugzilla XMLRPC API
to get bug status and summary from external trackers that are Bugzilla systems. This should be changed to use the 3.X API which is more widespread. We need do the following:

1) Check that the external tracker is a Bugzilla system
2) Check that the external Bugzilla system is 3.0 or later
3) USe Bug.get() to get the status and summary of the bug report.
4) Show any error in the external bug table if not able to see the bug.

Also if the bug id is for the local system such as showing a related bug that is not necessarily a dependency or a duplicate (such as a bug containing additional information), we should use the database directly. Should we instead create a special field for related bugs? Should we use the tagging method instead?
Comment 1 Kevin Baker 2008-10-15 12:22:39 EDT
5) Timeout with appropriate error message
6) Perhaps a flag on the Bug.get to say 'norecursion'
Comment 2 Kevin Baker 2008-10-15 13:01:25 EDT
These are the culprits causing recursion

121601 -> 158989    # pair
158989 -> 121601

150267 -> 150267    # points to self!

160539 -> 160539    # points to self!

382061 -> 428512    # pair
428512 -> 382061

451399 -> 451896    # pair
451896 -> 451399


Choices:

1) stop external_bug references to self and use some other mechanism to state relationships between bugs on the same host. This might be preferable since there are RFE's out there for other types of relationships besides blocks/depends-on like clone etc.

2) allow external bug references to self but enforce some rules to stop recusion and silliness like loops and self-pointers
Comment 3 David Lawrence 2010-01-15 12:33:18 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 4 David Lawrence 2010-08-25 17:41:39 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 7 Simon Green 2012-05-20 06:43:20 EDT
All Bugzilla based external trackers will be removed as part of bug 817428, so this will be marked as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.