Bug 467156 - Kernel panic in nf_unregister_sockopt
Kernel panic in nf_unregister_sockopt
Status: CLOSED DUPLICATE of bug 456664
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 23:40 EDT by Chris Kloiber
Modified: 2009-04-07 15:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 15:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2008-10-15 23:40:47 EDT
Description of problem:

# service iptables restart causes this panic, reboot. Happens on both kernel-smp-2.6.9-78.0.1 and kernel-smp-2.6.9-78.0.5

Oct 15 16:08:39 qu4tro kernel: Unable to handle kernel paging request at virtual address f88f05e8
Oct 15 16:08:39 qu4tro kernel:  printing eip:
Oct 15 16:08:39 qu4tro kernel: c0294afa
Oct 15 16:08:39 qu4tro kernel: *pde = 00000000
Oct 15 16:08:39 qu4tro kernel: Oops: 0000 [#1]
Oct 15 16:08:39 qu4tro kernel: SMP 
Oct 15 16:08:39 qu4tro kernel: Modules linked in: softdog md5 ipv6 autofs4 i2c_dev i2c_core ip_conntrack cpufreq_powersave dm_mirror dm_mod 
button battery ac uhci_hcd ehci_hcd e1000 floppy ata_piix libata ext3 jbd 3w_xxxx sd_mod scsi_mod
Oct 15 16:08:39 qu4tro kernel: CPU:    0
Oct 15 16:08:39 qu4tro kernel: EIP:    0060:[<c0294afa>]    Not tainted VLI
Oct 15 16:08:39 qu4tro kernel: EFLAGS: 00010212   (2.6.9-78.0.5.ELsmp) 
Oct 15 16:08:39 qu4tro kernel: EIP is at nf_unregister_sockopt+0x48/0x83
Oct 15 16:08:39 qu4tro kernel: eax: 00000002   ebx: c035e784   ecx: f7a8f840   edx: f88f05e0
Oct 15 16:08:39 qu4tro kernel: esi: f896a7e0   edi: 00000000   ebp: f5315000   esp: f5315f5c
Oct 15 16:08:39 qu4tro kernel: ds: 007b   es: 007b   ss: 0068
Oct 15 16:08:39 qu4tro kernel: Process modprobe (pid: 4195, threadinfo=f5315000 task=f310c230)
Oct 15 16:08:39 qu4tro kernel: Stack: 00000000 c0337ba8 f8961769 f896ac80 c01373ce 00000000 635f7069 746e6e6f 
Oct 15 16:08:40 qu4tro kernel:        6b636172 c0151e00 eefc93c4 f36b51d4 c01521f2 b7fc1000 b7fc2000 b7fc2000 
Oct 15 16:08:40 qu4tro kernel:        b7fc2000 f683db74 eefc9380 eefc93b0 00000000 f5315000 08b98840 00000000 
Oct 15 16:08:40 qu4tro kernel: Call Trace:
Oct 15 16:08:40 qu4tro kernel:  [<f8961769>] init_or_cleanup+0x1e6/0x1ea [ip_conntrack]
Oct 15 16:08:40 qu4tro kernel:  [<c01373ce>] sys_delete_module+0x13b/0x184
Oct 15 16:08:40 qu4tro kernel:  [<c0151e00>] free_pgtables+0x12/0x7b
Oct 15 16:08:40 qu4tro kernel:  [<c01521f2>] do_munmap+0x108/0x116
Oct 15 16:08:40 qu4tro kernel:  [<c02e09b7>] syscall_call+0x7/0xb
Oct 15 16:08:40 qu4tro kernel: Code: 04 00 89 d9 f0 ff 0d 84 e7 35 c0 0f 88 93 0c 00 00 8b 0d 9c e7 35 c0 8b 01 0f 18 00 90 81 f9 9c e7 35 c
0 74 2f 8b 51 08 8b 46 08 <39> 42 08 8b 11 75 1e 8b 41 04 89 42 04 89 10 89 c8 c7 01 00 01 
Oct 15 16:08:40 qu4tro kernel:  <0>Fatal exception: panic in 5 seconds


How reproducible:

100%
Comment 1 Chris Kloiber 2008-10-30 21:52:55 EDT
No acknowledgement of the issue yet?
Comment 2 John Newbigin 2008-12-17 22:43:33 EST
service iptables stop will also trigger the bug so we also see this during system shutdown.

kernel 2.6.9-78.0.8.ELsmp (RHEL4 i686).

A workaround is to edit /etc/sysconfig/iptables-config and set

IPTABLES_MODULES_UNLOAD="no"
Comment 3 John Newbigin 2008-12-17 22:48:16 EST
This is probably a duplicate of #456664
Comment 4 Linda Wang 2009-04-07 15:15:32 EDT
indeed, the panic traceback instruction is the same.

*** This bug has been marked as a duplicate of bug 456664 ***

Note You need to log in before you can comment on or make changes to this bug.