Bug 467168 - can't quit scim
can't quit scim
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 03:25 EDT by Alex Chiang
Modified: 2008-10-30 03:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 03:25:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bogus scim menu option (143.56 KB, image/png)
2008-10-29 11:59 EDT, Alex Chiang
no flags Details

  None (edit)
Description Alex Chiang 2008-10-16 03:25:42 EDT
Description of problem:
SCIM puts a little icon in my panel during a default F10 install. I try to quit it by right-clicking on the icon and selecting quit. The icon goes away and then reappears.

Version-Release number of selected component (if applicable):
Version    : 1.4.7
Release    : 34.fc10


How reproducible:
100%

Steps to Reproduce:
1. Attempt to quit SCIM
2. Fail

  
Actual results:
SCIM appears to be unkillable.

Expected results:
SCIM should quit when I ask it to go away

Additional info:
Comment 1 Peng Huang 2008-10-23 20:40:12 EDT
Please use im-chooser to disable SCIM.
Comment 2 Alex Chiang 2008-10-29 11:59:06 EDT
Created attachment 321817 [details]
bogus scim menu option

I'm sorry, this bug needs to be re-opened.

Until I installed F10, I happily had no idea what scim was, as I never needed it.

Now, this little scim panel thingy is installed by default; as a user, I never asked for it, and I _still_ don't need it.

How do you think a normal person is going to try and make this applet go away? A normal person is going to click around on it, until she sees the "exit" menu option, and then say, "ah ha! now i'm happy because i know how to make this thing go away."

You click on "exit" and then the applet comes back. What kind of user experience do you think that is?

Telling the user that "no, _that_ exit option doesn't work, you need to exit it some _other_ way" is just absolutely ridiculous.

From my perspective, you have several options, in order of preference, best to worst.

1) Stop running scim-panel-gtk or scim-helper-manager or scim-launcher or whatever by default.

2) Make the exit menu option actually work. If a user says "exit", don't exit and relaunch. Quit the applet and make the tray icon GO AWAY.

3) Remove the exit menu option altogether, make the user hunt around in the SCIM Setup menu, guess and pray that unclicking Panel->GTK->Show tray icon actually does something.

I'm sorry if I sound annoyed, but we should not be shipping software with such an unfriendly user experience. I hope you understand my perspective.
Comment 3 Peng Huang 2008-10-29 23:42:48 EDT
Hi Tagoh-san,

Do you have any idea about this problem? Could we fix this problem in im-chooser or imsettings? 
For example:
When imsettings find the input method process exits, imsettings should disable the input method and change im module back to none.
Comment 4 Akira TAGOH 2008-10-30 01:02:37 EDT
Well, I don't think it would really helps, because it won't goes away until all of input context receives the focus change and so on to apply the change through xsettings. which is a gtk+ bug as you know. I'm thinking of improve that with the certain way now BTW.
Comment 5 Jens Petersen 2008-10-30 03:25:43 EDT
(In reply to comment #2)
> 1) Stop running scim-panel-gtk or scim-helper-manager or scim-launcher or
> whatever by default.

scim is not run by default in F10 unless your desktop is run in an Asian locale.
You may have clicked on the imsettings-applet and triggered scim that way,
but it no longer is shown by default in current rawhide.

> 3) Remove the exit menu option altogether

Yes, that probably makes more sense for scim actually.

> I'm sorry if I sound annoyed, but we should not be shipping software with such
> an unfriendly user experience.

For F11 we are planning to move to ibus which helps with this problem.

Note You need to log in before you can comment on or make changes to this bug.