Bug 467186 - xorg-x11-drv-i810 "intel" man page is broken
xorg-x11-drv-i810 "intel" man page is broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: EasyFix
: 484890 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 05:36 EDT by Jan Iven
Modified: 2010-03-14 17:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
previously, no man page was provided to describe the "intel" driver included in this package, only the "i810" driver. A separate man page is now supplied for each driver.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Iven 2008-10-16 05:36:51 EDT
Description of problem:

the man page for the "intel" X11 driver in RHEL5 is self-referencing:

$ zcat /usr/share/man/man4/intel.4.gz
.so man4/intel.4

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-9.13.el5.i386

How reproducible:
always

Steps to Reproduce:
1. man 4 intel

  
Actual results:

(empty)

Expected results:

(man page with driver options and supported hardware types etc)

Additional info:
perhaps the page wants to redirect to the "i810" driver man page, but since "i810" and "intel" actually are two different drivers (shared libs), I would guess they support different hardware - but cannot tell.
Comment 1 Matěj Cepl 2009-02-19 12:43:26 EST
*** Bug 484890 has been marked as a duplicate of this bug. ***
Comment 2 RHEL Product and Program Management 2009-03-11 11:39:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Zack Cerza 2009-03-24 13:20:49 EDT
Acked.
Comment 4 Adam Jackson 2009-05-13 17:08:07 EDT
Fixed in xorg-x11-drv-i810 1.6.5-9.22.el5

MODIFIED
Comment 6 Mark Gordon 2009-06-22 17:05:45 EDT
Fix verified using the 20090608.2 tree.
Comment 8 Ruediger Landmann 2009-08-22 05:08:10 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
previously, no man page was provided to describe the "intel" driver included in this package, only the "i810" driver. A separate man page is now supplied for each driver.
Comment 9 errata-xmlrpc 2009-09-02 07:55:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1391.html

Note You need to log in before you can comment on or make changes to this bug.