Bug 467190 - Xserver version 1.5.0 sluggish performance [NEEDINFO]
Xserver version 1.5.0 sluggish performance
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 06:02 EDT by Jugoslav Gacas
Modified: 2018-04-11 04:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:46:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcepl: needinfo? (jugoslav.gacas)


Attachments (Terms of Use)
Xserver log file (63.24 KB, text/plain)
2008-10-16 06:02 EDT, Jugoslav Gacas
no flags Details
my manually modified xorg.conf (785 bytes, text/plain)
2008-10-18 01:37 EDT, Jugoslav Gacas
no flags Details
Xserver log file with automatically created xorg.conf (67.27 KB, text/plain)
2008-10-19 02:33 EDT, Jugoslav Gacas
no flags Details
Xorg.0.log ATI Mobility 7500 (210.75 KB, application/octet-stream)
2008-10-21 12:06 EDT, Scott Dodson
no flags Details
xorg.conf ATI Mobility 7500 (670 bytes, application/octet-stream)
2008-10-21 12:07 EDT, Scott Dodson
no flags Details

  None (edit)
Description Jugoslav Gacas 2008-10-16 06:02:02 EDT
Created attachment 320536 [details]
Xserver log file

Description of problem:
After upgrading to Xserver version 1.5.0 I noticed its performance is sluggish compared to version 1.4.99. There is also entry in xorg mailing list about this problem: http://lists.freedesktop.org/archives/xorg/2008-September/038500.html. It seems that the solution is to upgrade to version 1.5.1. Can someone confirm that this solution works, and if it works is there a chance that version 1.5.1 hits fedora updates repositories?

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg.i386 version 1.5.0-2.fc9

How reproducible:
Just use version 1.5.0 and compare its performance to version 1.4.99

Steps to Reproduce:

  
Actual results:
Sluggish performance

Expected results:
Performance as good as it was with version 1.4.99

Additional info:
Comment 1 Matěj Cepl 2008-10-17 05:39:18 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Matěj Cepl 2008-10-17 20:07:13 EDT
Could you please try to reboot the whole system with adding nomodeset to the
kernel command line, please? Does the performance improve? Could we get
/var/log/Xorg.*.log from such exercise as well, please?
Comment 3 Matěj Cepl 2008-10-17 20:08:05 EDT
In case it does improves with nomodeset, it looks like a duplicate of bug 467506.
Comment 4 Jugoslav Gacas 2008-10-18 01:37:20 EDT
Created attachment 320738 [details]
my manually modified xorg.conf
Comment 5 Jugoslav Gacas 2008-10-19 02:33:06 EDT
Created attachment 320789 [details]
Xserver log file with automatically created xorg.conf
Comment 6 Jugoslav Gacas 2008-10-19 02:43:15 EDT
Adding nomodeset to kernel command line didn't improve performance. But deleting the xorg.conf and rebooting Xserver did. Now desktop feels faster and snappier. But it is still noticable slower compared to Xserver 1.4.99 with EXA acceleration turned on. EXA acceleration is essential to me because I use ati X1650pro graphic card which only supports textured Xv, which only works if EXA acceleration is turned on, and I watch a lot of videos on my fedora box. All this sounds like the problem mentioned in xorg mailing list, but I could be wrong.
Comment 7 Scott Dodson 2008-10-21 11:55:10 EDT
I've added nomodeset and my machine fails to boot properly, I get GRUB and then nothing more. I have ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] rev 0


I've also tried xorg-x11-server 1.5.2 packages from koji:

Linux localhost.localdomain 2.6.27.3-30.rc1.fc10.i686 #1 SMP Mon Oct 20 01:35:32 EDT 2008 i686 i686 i386 GNU/Linux

xorg-x11-server-Xvfb-1.5.2-8.fc10.i386
xorg-x11-server-Xephyr-1.5.2-8.fc10.i386
xorg-x11-server-utils-7.4-3.fc10.i386
xorg-x11-server-common-1.5.2-8.fc10.i386
xorg-x11-server-Xdmx-1.5.2-8.fc10.i386
xorg-x11-server-Xorg-1.5.2-8.fc10.i386
xorg-x11-server-Xnest-1.5.2-8.fc10.i386
xorg-x11-drv-ati-6.9.0-29.fc10.i386
Comment 8 Scott Dodson 2008-10-21 12:04:08 EDT
Sorry, I was incorrect in stating the behavior with nomodeset. When I try nomodeset I do not get a prompt for my LUKs password. It boots fine up to that point.
Comment 9 Scott Dodson 2008-10-21 12:06:24 EDT
Created attachment 321025 [details]
Xorg.0.log ATI Mobility 7500
Comment 10 Scott Dodson 2008-10-21 12:07:39 EDT
Created attachment 321026 [details]
xorg.conf ATI Mobility 7500
Comment 11 Jan Kratochvil 2008-10-21 12:19:55 EDT
(In reply to comment #8)
> Sorry, I was incorrect in stating the behavior with nomodeset. When I try
> nomodeset I do not get a prompt for my LUKs password. It boots fine up to that
> point.

Have you tried typing it blindly?  It is just messed in middle of the screen full of text.
Comment 12 Scott Dodson 2008-10-29 20:30:47 EDT
Typing the password blindly just echos it back to my screen. I also get the oops described in RHBZ 469119 when using the nomodeset option.
Comment 13 Matěj Cepl 2008-10-30 05:56:43 EDT
This seems to go somewhere to the kernel-lang. Can we get /var/log/messages and /var/log/dmesg attached to this bug report, please?
Comment 14 Bug Zapper 2009-06-09 22:58:48 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-07-14 12:46:21 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.