Bug 467215 - [KDE] Unix-style copy-paste (using middle button) produces inconsistent results.
[KDE] Unix-style copy-paste (using middle button) produces inconsistent results.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 08:49 EDT by Gilboa Davara
Modified: 2008-11-24 08:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 08:24:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2008-10-16 08:49:56 EDT
Description of problem:
When trying to copy paste text from/to terminal and (g)vim to/from oowriter, I'm getting inconsistent results.

Version-Release number of selected component (if applicable):
$ rpm -qa | egrep 'openoffice|kdebase' | sort
kdebase3-3.5.10-2.fc9.x86_64
kdebase3-devel-3.5.10-2.fc9.x86_64
kdebase3-libs-3.5.10-2.fc9.x86_64
kdebase3-pim-ioslaves-3.5.10-2.fc9.x86_64
kdebase-4.1.2-2.fc9.x86_64
kdebase-devel-4.1.2-2.fc9.x86_64
kdebase-libs-4.1.2-2.fc9.x86_64
kdebase-runtime-4.1.2-4.fc9.x86_64
kdebase-runtime-libs-4.1.2-4.fc9.x86_64
kdebase-workspace-4.1.2-2.fc9.x86_64
kdebase-workspace-devel-4.1.2-2.fc9.x86_64
kdebase-workspace-libs-4.1.2-2.fc9.x86_64
kdebase-workspace-wallpapers-4.1.2-2.fc9.x86_64
openoffice.org-base-2.4.1-17.6.fc9.x86_64
openoffice.org-calc-2.4.1-17.6.fc9.x86_64
openoffice.org-core-2.4.1-17.6.fc9.x86_64
openoffice.org-draw-2.4.1-17.6.fc9.x86_64
openoffice.org-extendedPDF-1.4-4.fc9.noarch
openoffice.org-graphicfilter-2.4.1-17.6.fc9.x86_64
openoffice.org-impress-2.4.1-17.6.fc9.x86_64
openoffice.org-langpack-he_IL-2.4.1-17.6.fc9.x86_64
openoffice.org-math-2.4.1-17.6.fc9.x86_64
openoffice.org-writer-2.4.1-17.6.fc9.x86_64
openoffice.org-writer2latex-0.5-2.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start a KDE terminal.
2. Start a oowriter session.
3. Mark some text in side the terminal.
4. Middle click inside the oowriter.

OR:
3. Mark some text inside oowriter.
4. Check the contents of the KDE clipboard.
  
Actual results:
One of the following:
- Nothing is being copied.
- Parts of the text is being copied.
- Previous clipboard contents is being copied.
- Marking text in oowriter doesn't appear the KDE clipboard.

Expected results:
Working copy-and-paste.

Additional info:
I did find a reference to (what seems to be) this bug in Ubuntu's launchpad:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/151093
Comment 1 Caolan McNamara 2008-10-16 09:21:25 EDT
If I run OOo and konsole from inside a GNOME session I don't see any problems.

In the past I've seen that "klipper" can cause plenty of trouble for applications. I don't know if that is still the case though.
Comment 2 Gilboa Davara 2008-10-16 13:06:37 EDT
Should this bug be reported against klipper (kdebase) instead?
Comment 3 Caolan McNamara 2008-10-16 17:57:39 EDT
Well as a KDE environment issue rather than GNOME it'll get less attention from me than if it was trivial to reproduce. But is the problems visible under KDE if klipper is disabled ?, if it is then klipper would be absolved from blame.
Comment 4 Gilboa Davara 2008-10-17 01:51:33 EDT
Closing klipper doesn't improve things - without it I'm only getting garbage when trying to use unix-style copy-paste.

- Gilboa
Comment 5 Jaroslav Reznik 2008-10-17 04:30:35 EDT
It's working for me in KDE 4.1.2. First one "how-to reproduce" is standard selection behaviour - it should work even without Klipper, second one is Klipper feature - default is not to synchronize clipboard content with selection, so you can see it in Klipper, but content is still separate. So selection is not in clipboard!
Comment 6 Gilboa Davara 2008-10-20 05:01:02 EDT
One problem was indeed missing klipper option (Sync with selection), thanks.
However, I still cannot seem to select->paste (MB) within OO itself.

Steps to reproduce:
1. Fire up oowriter.
2. Create a new document.
3. Write: Hello.
4. Mark the hello string.
5. New line.
6. Try to paste the line using the middle button.

P.S. just tested it on my CentOS 5.2 machine w/ KDE 3.5.2 - same results.
In both case the klipper sees the "Hello" string, but OO refuses to paste it.

- Gilboa
Comment 7 David Tardon 2008-10-20 06:25:17 EDT
dtardon->gilboad: To get it working, the text intended to be copied must remain selected. I'm not sure if it's an error or if this behaviour is allowed for X selections. OOo is the only one application which behaves in that manner.

Try that:
1. Fire up oowriter.
2. Create a new document.
3. Write: Hello.
4. New line
5. Mark the hello string + the end-of-line
6. Press middle button somewhere below the selected line
Comment 8 Caolan McNamara 2008-10-24 04:31:23 EDT
If there is no klipper running then comment #6 is the behaviour for OOo and e.g. gedit. But with klipper running the klipper magic to keep the last created selection in the selection buffer works for gedit's selection, but not for OOo's selection. i.e. #6 then works for gedit, but not for OOo

(FWIW dtrans is the OOo module which handles selection/clipboard stuff)
Comment 9 Gilboa Davara 2008-10-28 06:59:41 EDT
David,

With or without klipper, your example doesn't work. (Read: text selection remains persistent, but nothing gets copied)

Caolan,

gedit works just fine; with or w/o klipper.

- Gilboa
Comment 10 David Tardon 2008-10-28 09:24:32 EDT
dtardon->gilboad: Do you have Tools->Options->Openoffice.org->View->'Middle mouse button' set to 'Paste clipboard'?
Comment 11 Gilboa Davara 2008-10-28 10:02:07 EDT
Yep.

- Gilboa
Comment 12 David Tardon 2008-10-29 05:58:13 EDT
dtardon->gilboa: With or without clipper, the example in comment 7 works for me (openoffice.org-writer-2.4.1-17.6.x86_64, kdebase-4.1.2-5.x86_64). Middle-button pasting into konsole works in the same way. I'm running KDE on the testing virtual machine.
Comment 13 Gilboa Davara 2008-11-24 07:41:25 EST
Gaah.
Problem disappeared.

openoffice.org-writer-2.4.2-18.1.fc9.x86_64

Oh well - no idea what-type-of-voodoo magic is at work here, but thanks for help! :)

Feel free to close as WORKSFORME.

- Gilboa
Comment 14 David Tardon 2008-11-24 08:24:31 EST
Okay.

Note You need to log in before you can comment on or make changes to this bug.