Bug 467404 - Remove ALSA plugin in F11
Remove ALSA plugin in F11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 06:44 EDT by Bastien Nocera
Modified: 2009-01-17 07:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-17 07:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-10-17 06:44:50 EDT
People should use Pulseaudio for that, it works as well as ALSA does...
Comment 1 Marcel Holtmann 2008-10-17 11:08:21 EDT
This is why I asked you to put the ALSA plugin into a separate package called bluez-alsa. You don't have to install it by default anymore, but you need to leave it there since some people might still need it for reasons you don't know.

Also the Bluetooth plugin for PulseAudio is still marked as experimental.
Comment 2 Bastien Nocera 2008-10-17 11:18:14 EDT
(In reply to comment #1)
> This is why I asked you to put the ALSA plugin into a separate package called
> bluez-alsa. You don't have to install it by default anymore, but you need to
> leave it there since some people might still need it for reasons you don't
> know.

It's already in bluez-alsa.

> Also the Bluetooth plugin for PulseAudio is still marked as experimental.

Yes, but we don't want to have to support 2 code paths in F11. So we'll remove the ALSA plugin in F11, and do whatever is needed to get the PulseAudio support working out-of-the-box.

That's for F11 release, meaning in more than 6 months' time.
Comment 3 David Woodhouse 2008-10-17 12:53:24 EDT
Stop installing bluez-alsa by default, by all means -- but don't stop shipping it completely.

There is no way that saying "you MUST use PulseAudio", without a safety net to fall back to, is going to be sane for F11. Even for "normal" users; let alone Bluetooth.
Comment 4 Matthias Clasen 2008-12-10 23:18:58 EST
Would now be a good time to change the comps entry for bluez-alsa to "optional" ?
Comment 5 Matthias Clasen 2009-01-16 21:52:18 EST
Ping. Time to act on this now ?
Comment 6 David Woodhouse 2009-01-17 05:53:46 EST
To change the comps entry to optional, by all means. Please don't kill the package entirely.
Comment 7 Matthias Clasen 2009-01-17 07:49:49 EST
Ok, done.

Note You need to log in before you can comment on or make changes to this bug.