Bug 467433 - vdr bidi support
vdr bidi support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vdr (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 09:20 EDT by alrawab
Modified: 2008-10-17 14:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-17 14:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdr-1.7.x bidi support (29.73 KB, patch)
2008-10-17 09:24 EDT, alrawab
no flags Details | Diff

  None (edit)
Description alrawab 2008-10-17 09:20:49 EDT
Description of problem:
add BiDi langugaes support to vdr

Description of problem:
Arabic language and derived scripts and sister Semitic languages needs BiDi
support appear correctly as they are written from right not left

Version-Release number of selected component (if applicable):
1.7.0
Comment 1 alrawab 2008-10-17 09:24:37 EDT
Created attachment 320661 [details]
vdr-1.7.x bidi support

add BiDi langugaes support to vdr

Description of problem:
Arabic language and derived scripts and sister Semitic languages needs BiDi
support appear correctly as they are written from right not left

Version-Release number of selected component (if applicable):
1.7.x
Comment 2 Ville Skyttä 2008-10-17 14:15:18 EDT
The patch you submitted appears to be against VDR 1.7.0.  We're at VDR 1.6.0 currently in Fedora, and I personally don't have even thought about moving to 1.7.0 yet (I think it's far too early for that - if for nothing else, DVB driver flux).

Has the patch been submitted upstream to Klaus?  What were his thoughts about it?

How does compiling with BIDI affect non-Arabic/Semitic language support in VDR?  Do they still work as they used to?
Comment 3 Ville-Pekka Vainio 2008-10-17 14:22:45 EDT
Ville, there's been two bugs submitted about this. The patch against 1.6 is attached to #467323 .
Comment 4 alrawab 2008-10-17 14:26:11 EDT
it's the work fine on vdr-1.6.0 the same patch(it's orginally vdr-1.6.0)
and about klaus yep i upstream it and he replayed he may take a while to adopt it, because he working on S2API stuff
and HDTV.
regards
Comment 5 Ville Skyttä 2008-10-17 14:32:52 EDT
Ah, I see.  So I suppose we should close this bug report as we're not yet even in planning stages for VDR 1.7.0, and discuss bug 467323 instead?

Note You need to log in before you can comment on or make changes to this bug.