Bug 467443 - perl-NOCpulse-Utils provides perl(NOCPulse::Module)
perl-NOCpulse-Utils provides perl(NOCPulse::Module)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Milan Zázrivec
:
Depends On:
Blocks: 463877
  Show dependency treegraph
 
Reported: 2008-10-17 10:43 EDT by Milan Zázrivec
Modified: 2009-09-10 14:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:49:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2008-10-17 10:43:29 EDT
Description of problem:
Satellite-5.3.0-RHEL5-re20081017.1:

# rpm -qp --provides perl-NOCpulse-Utils-1.14.7-1.el5.noarch.rpm 
perl(NOCPulse::Module)  
perl(NOCpulse::Utils::Error)  
perl(NOCpulse::Utils::XML)  
perl-NOCpulse-Utils = 1.14.7-1.el5

Note the capital P in "perl(NOCPulse::Module)" which I think is
incorrect. Not sure when this changed, but on Satellite 5.2.0:

# rpm -q --provides perl-NOCpulse-Utils
perl(Module)  
perl(NOCpulse::Module)  
perl(NOCpulse::Utils::Error)  
perl(NOCpulse::Utils::XML)  
perl-NOCpulse-Utils = 1.14.2-9.el5

This problem causes dependency problems (i.e. cannot install this
Satellite compose)

Version-Release number of selected component (if applicable):
perl-NOCpulse-Utils-1.14.7-1
Comment 1 Clifford Perry 2008-10-17 13:17:27 EDT
[isabella@localhost cliff-tmp]$ egrep -irl 'provi|require' 2 7
2/BUILD.spec
7/perl-NOCpulse-Utils.spec
[isabella@localhost cliff-tmp]$ egrep -ir 'provi|require' 2 7
2/BUILD.spec:Provides:     perl(NOCpulse::Module)
2/BUILD.spec:%{name} provides miscellaneous utility packages
7/perl-NOCpulse-Utils.spec:Requires:     perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
7/perl-NOCpulse-Utils.spec:NOCpulse provides application, network, systems and transaction monitoring,
7/perl-NOCpulse-Utils.spec:This package provides miscellaneous utility modules.
7/perl-NOCpulse-Utils.spec:- remove nocpulse-common from requires
[isabella@localhost cliff-tmp]$ 


old package was hard coded Provides. new package does not. Still looking :)
Comment 2 Clifford Perry 2008-10-17 13:23:31 EDT
diff -uNr 2/perl-NOCpulse-Utils-svn-r173460/Module.pm 7/perl-NOCpulse-Utils-1.14.7/Module.pm
--- 2/perl-NOCpulse-Utils-svn-r173460/Module.pm 2008-05-05 09:40:11.000000000 -0400
+++ 7/perl-NOCpulse-Utils-1.14.7/Module.pm      2008-10-14 09:54:46.000000000 -0400
@@ -1,12 +1,25 @@
-package Module;
-
+package NOCPulse::Module;
+#


^^^ This seems to be the 'typo' location. 

[isabella@localhost perl-NOCpulse-Utils-1.14.7]$ grep -r NOCPulse * 
Module.pm:package NOCPulse::Module;
[isabella@localhost perl-NOCpulse-Utils-1.14.7]$ 

No other part of code within this src points to NOCPulse, everything else uses NOCpulse.
Comment 3 Miroslav Suchý 2008-10-20 04:58:19 EDT
I do confirm Cliff findings.
Fixed in commit e8945967fccd9e24b7a85bcacc26131b1a5b81b1.
Tagged as perl-NOCpulse-Utils-1.14.8-1
Comment 4 Milan Zázrivec 2008-10-22 06:02:21 EDT
Verified:
# rpm -qp --provides perl-NOCpulse-Utils-1.14.9-1.el4.noarch.rpm 
perl(NOCpulse::Module)  
perl(NOCpulse::Utils::Error)  
perl(NOCpulse::Utils::XML)  
perl-NOCpulse-Utils = 1.14.9-1.el4
Comment 5 Jan Pazdziora 2009-08-19 10:18:33 EDT
[root@xen5 ~]# rpm -q perl-NOCpulse-Utils
perl-NOCpulse-Utils-1.14.11-1.el5sat.noarch
[root@xen5 ~]# rpm -q --provides perl-NOCpulse-Utils
perl(NOCpulse::Module)  
perl(NOCpulse::Utils::Error)  
perl(NOCpulse::Utils::XML)  
perl-NOCpulse-Utils = 1.14.11-1.el5sat

Moving to RELEASE_PENDING.
Comment 6 Brandon Perkins 2009-09-10 14:49:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.