Bug 46746 - Install fails initializing swap
Install fails initializing swap
Status: CLOSED DUPLICATE of bug 46450
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-30 01:16 EDT by Brent Nordquist
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-01 12:56:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2001-06-30 01:16:21 EDT
Description of Problem:
During an FTP TUI install of Fairfax beta1, the install stopped with a
fatal error initializing swap on device hda5.  A second (seemingly)
identical install with the same options then succeeded.

How Reproducible:
Only happened once.  It's possible that the first attempt did something
with swap that caused the second attempt to succeed.

Steps to Reproduce:
1. Choose "Autopartitioning".
2. Choose "Remove all partitions" with hda [*] checked; I believe that this
machine had two primary ext2 partitions (hda1=256MB and hda2=remaining of
8GB) and nothing else (NO swap) when this install started.
3. The auto-selected configuration looked like this:
  /dev/hda1  1-1018  7985M  ext3  /
  /dev/hda2  1019-1042  188M  swap
  /dev/hda3  1043-1048  47M  ext3  /boot
4. Highlight /dev/hda1 and choose "Delete".  (hda2 moves to hda1 etc., free
space listed at end of drive)
5. Add 256M / partition (hda1 moves to hda2 etc., / goes on hda1)
6. Add 512M /var partition (hda1 moves to hda2 etc., /var goes on hda1)
7. Add 2048M /usr partition (hda1 moves to hda2 etc., /usr goes on hda1)
8. Add /export partition with "Fill all available" checked (goes at the end
of the disk) -- when all this is finished we have:
  /dev/hda1  1-261  2047M  ext3  /usr
  /dev/hda2  262-326  509M  ext3  /var
  /dev/hda3  327-259  258M  ext3  /
  /dev/hda4  360-1048  5404M  Extended
    /dev/hda5  360-383  188M  swap
    /dev/hda6  384-389  47M  ext3  /boot
    /dev/hda7  390-1048  5164M  ext3  /export
[I must say that looks really strange to me... is this "intelligent"
partitioning to a purpose, or is it just the order I did things in?]
9. Fill in a bunch more screens and get the "/tmp/install.log" message.

Actual Results:
A dialog titled "Error" that reads:  "An error occurred trying to
initialize swap on device hda5.  This problem is serious, and the install
cannot continue.  Press Enter to reboot your system."  F3 shows:
* Detected 96M of memory
* Swap attempt of 96M to 192M

Expected Results:
The install should begin.

Additional Information:
I think the fact that I began the first attempt with two ext2 partitions
and no swap partition(s) (see above) may be relevant?  In any case, I did
the same things the second time, and then it worked.
Comment 1 Matt Wilson 2001-07-01 12:56:49 EDT
Jeremy, this looks like more failure to reread partition table bugs.
Comment 2 Matt Wilson 2001-07-01 12:58:42 EDT

*** This bug has been marked as a duplicate of 46450 ***

Note You need to log in before you can comment on or make changes to this bug.