Bug 467506 - 5 second X stucks when not using nomodeset
5 second X stucks when not using nomodeset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 16:19 EDT by Jan Kratochvil
Modified: 2018-04-11 10:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 02:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.72 KB, text/plain)
2008-10-17 16:19 EDT, Jan Kratochvil
no flags Details
/var/log/Xorg.0.log on kernel-2.6.27-17.fc10.x86_64 with no extra kernel options (86.41 KB, text/plain)
2008-10-17 16:21 EDT, Jan Kratochvil
no flags Details
/var/log/Xorg.0.log on kernel-2.6.27-17.fc10.x86_64 after specifying nomodeset (111.51 KB, text/plain)
2008-10-17 16:22 EDT, Jan Kratochvil
no flags Details
boot messages on kernel-2.6.27-17.fc10.x86_64 with no extra kernel options (30.09 KB, text/plain)
2008-10-17 16:25 EDT, Jan Kratochvil
no flags Details
boot messages on kernel-2.6.27-17.fc10.x86_64 after specifying nomodeset (29.43 KB, text/plain)
2008-10-17 16:26 EDT, Jan Kratochvil
no flags Details
Xorg.0.log kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 default (86.64 KB, text/plain)
2008-11-02 17:54 EST, Jan Kratochvil
no flags Details
dmesg kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 default (38.20 KB, text/plain)
2008-11-02 17:55 EST, Jan Kratochvil
no flags Details
Xorg.0.log kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 nomodeset (114.58 KB, text/plain)
2008-11-02 17:56 EST, Jan Kratochvil
no flags Details
dmesg.log kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 nomodeset (37.86 KB, text/plain)
2008-11-02 17:57 EST, Jan Kratochvil
no flags Details
Xorg.0.log kernel-2.6.27.5-88.fc10.x86_64 xorg-x11-drv-ati-6.9.0-42.fc10.x86_64 default (86.63 KB, text/plain)
2008-11-08 18:12 EST, Jan Kratochvil
no flags Details
dmesg.log kernel-2.6.27.5-88.fc10.x86_64 xorg-x11-drv-ati-6.9.0-42.fc10.x86_64 default (47.93 KB, text/plain)
2008-11-08 18:13 EST, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2008-10-17 16:19:46 EDT
Created attachment 320714 [details]
xorg.conf

Description of problem:
After switching from F9 to F10 kernel I get up to 10 second lockups in X.  IMO any larger memory transfers are terribly slow - switching vitrual desktops, switching larger windows etc.

Version-Release number of selected component (if applicable):
kernel-2.6.27-17.fc10.x86_64

How reproducible:
Slow X is a longterm problem for any post-F9 Rawhide kernels.
With kernel-2.6.27-17.fc10.x86_64 I tried it only once.

Steps to Reproduce:
1. Boot with default kernel (without nomodeset).
2. 24 virtual desktops, all the windows fullscreen, gnome-terminals,
   Firefox + Pidgin being switched on one virtual desktop
  
Actual results:
It takes 2-10 second to switch them.

Expected results:
Immediate response.

Additional info:
Specifying `nomodeset' for kernel makes it run X perfectly - like F9 kernels.

1400x1050
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400 (prog-if 00 [VGA controller])
	Subsystem: Lenovo Thinkpad T60 model 2007
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at d8000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 2000 [size=256]
	Memory at ee100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at ee120000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
	Kernel modules: radeon
Lenovo T60 (Red Hat machine), 3GB RAM
Tried many xorg.conf changes with no success before.
Comment 1 Jan Kratochvil 2008-10-17 16:21:19 EDT
Created attachment 320715 [details]
/var/log/Xorg.0.log on kernel-2.6.27-17.fc10.x86_64 with no extra kernel options
Comment 2 Jan Kratochvil 2008-10-17 16:22:15 EDT
Created attachment 320716 [details]
/var/log/Xorg.0.log on kernel-2.6.27-17.fc10.x86_64 after specifying nomodeset
Comment 3 Jan Kratochvil 2008-10-17 16:25:20 EDT
Created attachment 320717 [details]
boot messages on kernel-2.6.27-17.fc10.x86_64 with no extra kernel options
Comment 4 Jan Kratochvil 2008-10-17 16:26:09 EDT
Created attachment 320718 [details]
boot messages on kernel-2.6.27-17.fc10.x86_64 after specifying nomodeset
Comment 6 Dave Airlie 2008-11-02 03:48:56 EST
can you retry with some of the later F10 kernels/xorg-x11-drv-ati drivers?

need to know if we are still seeing this issue.
Comment 7 Jan Kratochvil 2008-11-02 17:54:50 EST
Created attachment 322243 [details]
Xorg.0.log kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 default
Comment 8 Jan Kratochvil 2008-11-02 17:55:45 EST
Created attachment 322244 [details]
dmesg kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 default
Comment 9 Jan Kratochvil 2008-11-02 17:56:58 EST
Created attachment 322245 [details]
Xorg.0.log kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 nomodeset
Comment 10 Jan Kratochvil 2008-11-02 17:57:44 EST
Created attachment 322246 [details]
dmesg.log kernel-2.6.27.4-69.fc10.x86_64 xorg-x11-drv-ati-6.9.0-41.fc10.x86_64 nomodeset
Comment 11 Jan Kratochvil 2008-11-02 18:01:27 EST
The problem still exists.
Pidgin + Firefox with two windows (5 + 8 tabs).
Not sure if the hangs are shorter but seen many at least 3+ seconds.
Hard to use almost to being unusable.
nomodeset seems to still fix it all.
Only tested not running F10 kernels for the normal use (ptrace Bug 468089).
Sure thanks for the updates, though.
Comment 12 Dave Airlie 2008-11-08 16:39:51 EST
Please test with the -88 kernel from koji to see if this still happens.
Comment 13 Jan Kratochvil 2008-11-08 18:12:09 EST
Created attachment 322973 [details]
Xorg.0.log kernel-2.6.27.5-88.fc10.x86_64 xorg-x11-drv-ati-6.9.0-42.fc10.x86_64 default
Comment 14 Jan Kratochvil 2008-11-08 18:13:53 EST
Created attachment 322974 [details]
dmesg.log kernel-2.6.27.5-88.fc10.x86_64 xorg-x11-drv-ati-6.9.0-42.fc10.x86_64 default
Comment 15 Jan Kratochvil 2008-11-08 18:16:21 EST
The problem still exists.
Pidgin + Firefox with one window (3 tabs).
Not sure if the hangs are shorter but seen many at least 6 seconds.
Hard to use almost to being unusable.
Sure thanks for the updates, though.
glxtest FPS went 110 -> 121 (improvement).compared
to kernel-2.6.25.10-86.fc9.x86_64 (the default nomodeset-like mode there).
Comment 16 Matěj Cepl 2008-11-15 20:24:06 EST
Looking at bug 471669 comment 8 -- Honzo, do you think you can decrease the number of your workspaces from 24 to some reasonable number (like 4) and test the speed? Maybe it is really about screwed up memory management or something like this, which has not been tested with so high number of workspaces.
Comment 17 Bug Zapper 2008-11-25 22:58:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Jan Kratochvil 2008-12-26 11:55:24 EST
Problem still exists although it is acceptable now (only about 0.5sec delays).
xorg-x11-drv-ati-6.9.0-63.fc10.x86_64
kernel-2.6.27.9-163.ptrace.fc10.x86_64
        Driver      "ati"
        Option      "AccelMethod" "EXA"
        Option      "DynamicClocks" "on"
(no kernel option - therefore default modeset)

It was working without any delays before on:
kernel-2.6.27.9-157.ptrace.fc10.x86_64 nomodeset
        Driver      "vesa"
Comment 19 Jan Kratochvil 2009-01-10 12:02:55 EST
If it helps the delays problem is the same for
        Driver      "radeonhd"
as is for
        Driver      "ati"
That "vesa" still cures that.
Comment 20 Jan Kratochvil 2009-10-12 02:03:50 EDT
Tried after a while and the problem is no longer present with:
xorg-x11-drv-ati-6.13.0-0.7.20091006git457646d73.fc12.x86_64
Comment 21 Jan Kratochvil 2009-10-12 02:05:05 EDT
Comment 20 is invalid, I forgot I use nomodeset now, I will try it without it.
Comment 22 Jan Kratochvil 2009-10-12 02:53:27 EDT
Verified Comment 20 without nomodeset, on kernel-2.6.31.1-56.fc12.x86_64.

Note You need to log in before you can comment on or make changes to this bug.