Bug 467537 - rhythmbox can damage RHEL installation while rebuilding
rhythmbox can damage RHEL installation while rebuilding
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhythmbox (Show other bugs)
5.2
All Linux
medium Severity high
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 00:50 EDT by Boris B. Zhmurov
Modified: 2014-09-08 07:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:18:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bb: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Boris B. Zhmurov 2008-10-18 00:50:12 EDT
Description of problem:
rebuilding the rhythmbox can corrupt the system (rm -rf /usr/lib/mozilla/) and fails to rebuild

Version-Release number of selected component (if applicable):
rhythmbox-0.11.6-1.8.el5_2

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild rhythmbox-0.11.6-1.8.el5_2.src.rpm

  
Actual results:
+ rm -rf /usr/lib/mozilla/
rm: cannot remove directory `/usr/lib/mozilla//extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}': Permission denied
rm: cannot remove directory `/usr/lib/mozilla//plugins': Permission denied
error: Bad exit status from /var/tmp/rpm-tmp.6937 (%install)


Expected results:
successful rebuild

Additional info:
The problem is the following:

# If we're building on a machine with mozilla-devel installed
rm -rf %{_libdir}/mozilla/
Comment 1 RHEL Product and Program Management 2014-03-07 07:48:45 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:18:32 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.