Bug 467564 - kdepim libraries renamed from kdepimlibs --> kdepim-libs
kdepim libraries renamed from kdepimlibs --> kdepim-libs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdepimlibs (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 13:47 EDT by Hal Duston
Modified: 2008-10-18 14:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-18 13:55:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Duston 2008-10-18 13:47:10 EDT
Description of problem: Several KDE compenents require kdepimlibs >= 4.1.2, but kdepim-libs-4.1.2 provides kdepim-libs-4.1.2-3.fc10, causing most KDE components to fail the upgrade due to dependency issues.


Version-Release number of selected component (if applicable): 4.1.2-3.fc10


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
# rpmquery kdepimlibs kdepim-libs
kdepimlibs-4.1.1-2.fc10.x86_64
kdepim-libs-4.1.2-3.fc10.x86_64
#
Comment 1 Rex Dieter 2008-10-18 13:53:48 EDT
kdepim (and subpkg -libs) and kdepimlibs are 2 distinct packages as distributed by upstream kde.

Besides the admittedly potential confusion seeing both kdepimlibs and kdepim-libs, what exactly is the problem here?  You mention failed upgrades and dependency issues, what are you seeing exactly?
Comment 2 Kevin Kofler 2008-10-18 13:55:17 EDT
kdepimlibs and kdepim-libs are different packages, kdepim-libs contains the libraries which are part of kdepim, kdepimlibs is a separate upstream tarball.
Comment 3 Kevin Kofler 2008-10-18 13:58:07 EDT
But yes, you have to tell us the actual dependency issues if you want us to fix them.
Comment 4 Rex Dieter 2008-10-18 14:03:17 EDT
fwiw, on my f10/rawhide box, I have
kdepimlibs-4.1.2-2.fc10
Comment 5 Hal Duston 2008-10-18 14:16:33 EDT
OK, it appears to be some sort of bizzare timing thing.  When I did upgrade earlier, yum fetched most of kde*-4.1.2, but for some reason didn't retrieve the new kdepimlibs.  When I saw kdepim-libs, I assumed (incorrectly) that was it was a renamed package.  Doing another yum upgrade now fetches kdepimlibs and all is well.  Having kdepimlibs and kdepim-libs be completely different packages  I guess some days, you'll have that.

Note You need to log in before you can comment on or make changes to this bug.