Bug 467571 - RFE: update to 15.28.1.6
RFE: update to 15.28.1.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iwl3945-firmware (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 15:48 EDT by drago01
Modified: 2008-10-22 13:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 04:51:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2008-10-18 15:48:05 EDT
Currently we ship version 2.14.1.5 of the iwl3945 firmware in fedora, while there is a newer one 15.28.1.6 (released on 09-01-08, see http://intellinuxwireless.org/?n=downloads ) 

Please consider updating the fedora package to the current version.
Comment 1 Matthias Saou 2008-10-22 04:51:22 EDT
Looks like it's been updated by Intel to 15.28.2.8.

Note that this latest version is yet a different file name, so there will now be 3 firmware files in the package :

 * iwlwifi-3945.ucode : 2.14.4
 * iwlwifi-3945-1.ucode : 2.14.1.5
 * iwlwifi-3945-2.ucode : 15.28.2.8

I'm assuming the oldest file could be removed from Rawhide without any problem, but given how small it is, I don't think it's worth the risk.

Package should appear with the next Rawhide push, thanks for the report.
Comment 2 drago01 2008-10-22 10:53:53 EDT
(In reply to comment #1)
> Looks like it's been updated by Intel to 15.28.2.8.
> 
> Note that this latest version is yet a different file name, so there will now
> be 3 firmware files in the package :
> 
>  * iwlwifi-3945.ucode : 2.14.4
>  * iwlwifi-3945-1.ucode : 2.14.1.5

The lastest version of the -1 file is 15.28.1.8 see: http://marc.info/?l=linux-wireless&m=122461362432337&w=2 
It has the same fixes as 15.28.2.8 but works on older kernel versions (usefull for F8/F9)
Comment 3 Matthias Saou 2008-10-22 13:24:19 EDT
Very good catch! Rebuilding now.

Note You need to log in before you can comment on or make changes to this bug.