Bug 467586 - Intel 82562GT network card no longer works
Intel 82562GT network card no longer works
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 18:39 EDT by Jacek Pliszka
Modified: 2008-10-21 09:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 09:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Pliszka 2008-10-18 18:39:40 EDT
Description of problem:

Integrated network card Intel 82562GT in notebook GM965 chipset no longer works.
Worked with e1000e driver in F9 out-of-box. Does not work with F10 beta.

Version-Release number of selected component (if applicable):

2.6.27-0.352.rc7.git1.fc10.i686

How reproducible:

Install Fedora 10 beta - card no longer works. No module is loaded, loading e1000
does not work.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: This from working F9:
ls -vv
00:19.0 Ethernet controller: Intel Corporation 82562GT 10/100 Network Connection (rev 03)
	Subsystem: Hewlett-Packard Company Unknown device 30d8
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 22
	Region 0: Memory at e0600000 (32-bit, non-prefetchable) [size=128K]
	Region 1: Memory at e0620000 (32-bit, non-prefetchable) [size=4K]
	Region 2: I/O ports at 2020 [size=32]
	Capabilities: [c8] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=1 PME-
	Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
		Address: 0000000000000000  Data: 0000
	Kernel driver in use: e1000e
	Kernel modules: e1000e
and after modprobe e1000e:

[root@bond ~]# dmesg 
e1000e: Intel(R) PRO/1000 Network Driver - 0.3.3.3-k2
e1000e: Copyright (c) 1999-2008 Intel Corporation.
ACPI: PCI Interrupt 0000:00:19.0[A] -> GSI 22 (level, low) -> IRQ 22
PCI: Setting latency timer of device 0000:00:19.0 to 64
eth0: (PCI Express:2.5GB/s:Width x1) 00:1c:c4:cd:59:44
eth0: Intel(R) PRO/10/100 Network Connection
eth0: MAC: 4, PHY: 7, PBA No: ffffff-0ff
ADDRCONF(NETDEV_UP): eth0: link is not ready
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: None
eth0: 10/100 speed: disabling TSO
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

In the not working f10 beta, after loading e1000,only the first two lines are shown:
e1000: Intel(R) PRO/1000 Network Driver - 0.....
00: Copyright (c) 1999-2008 Intel Corporation.

There is also difference in /var/log/messages:

working F9:

Oct 18 20:20:49 bond kernel: e1000e: Intel(R) PRO/1000 Network Driver - 0.3.3.3-k2
Oct 18 20:20:49 bond kernel: e1000e: Copyright (c) 1999-2008 Intel Corporation.
Oct 18 20:20:49 bond kernel: ACPI: PCI Interrupt 0000:00:19.0[A] -> GSI 22 (level, low) -> IRQ 22
Oct 18 20:20:49 bond kernel: ssb: Sonics Silicon Backplane found on PCI device 0000:10:00.0
Oct 18 20:20:49 bond kernel: eth0: (PCI Express:2.5GB/s:Width x1) 00:1c:c4:cd:59:44
Oct 18 20:20:49 bond kernel: eth0: Intel(R) PRO/10/100 Network Connection
Oct 18 20:20:49 bond kernel: eth0: MAC: 4, PHY: 7, PBA No: ffffff-0ff

not working F10beta:

Oct 18 10:59:23 bond kernel: pci 0000:00:19.0: PME# supported from D0 D3hot D3cold
Oct 18 10:59:23 bond kernel: pci 0000:00:19.0: PME# disabled
Comment 1 Yanko Kaneti 2008-10-19 15:16:08 EDT
The beta had no e1000e driver because of the EEPROM/NVM corrupting bug.
You could try Snap1 or Snap2.

Note You need to log in before you can comment on or make changes to this bug.