Bug 467649 - gtkhtml3 should require glib2 >= 2.18
gtkhtml3 should require glib2 >= 2.18
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-19 20:50 EDT by Matt McCutchen
Modified: 2009-01-27 12:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-27 12:28:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matt McCutchen 2008-10-19 20:50:59 EDT
Description of problem:
I am using Fedora 9 but wanted to use the rawhide version of Evolution because it contains several bug fixes that are important to me, so I installed/upgraded the minimum required set of packages and attempted to "rpmbuild --rebuild evolution-2.24.0-3.fc10.src.rpm".  The build failed with this error:

Making all in tools
make[2]: Entering directory `/usr/local/src/rpm/BUILD/evolution-2.24.0/tools'
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC -DLDAP_DEPRECATED -I/usr/include/et -Wno-sign-compare -DG_DISABLE_DEPRECATED=1 -DPANGO_DISABLE_DEPRECATED=1 -DGDK_PIXBUF_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DEDS_DISABLE_DEPRECATED=1 -Wdeclaration-after-statement -Werror-implicit-function-declaration -UGNOME_DISABLE_DEPRECATED -fno-strict-aliasing -o .libs/killev killev.o -pthread  ../widgets/misc/.libs/libemiscwidgets.so /usr/local/src/rpm/BUILD/evolution-2.24.0/widgets/text/.libs/libetext.so /usr/local/src/rpm/BUILD/evolution-2.24.0/widgets/table/.libs/libetable.so /usr/local/src/rpm/BUILD/evolution-2.24.0/a11y/widgets/.libs/libevolution-widgets-a11y.so /usr/local/src/rpm/BUILD/evolution-2.24.0/a11y/.libs/libevolution-a11y.so /usr/local/src/rpm/BUILD/evolution-2.24.0/e-util/.libs/libeutil.so -lcamel-provider-1.2 -lgtkhtml-editor -lgtkhtml-3.14 -lenchant -lssl3 -lsmime3 -lnss3 -lnssutil3 ../e-util/.libs/libeutil.so -lgpilotd -lgpilotdcm -lgpilotdconduit -lpisock -lpisync -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lart_lgpl_2 -ledataserverui-1.2 -lglade-2.0 -lebook-1.2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgnome-2 -lpopt -lcamel-1.2 -ledataserver-1.2 -lsqlite3 -lxml2 -lgconf-2 -lsoup-2.4 -lbonobo-2 -lgio-2.0 -lbonobo-activation -lgmodule-2.0 -lORBit-2 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0 -lplds4 -lplc4 -lnspr4 -ldl -lpthread -lX11  -Wl,--rpath -Wl,/usr/lib/evolution/2.24
/usr/lib/gcc/i386-redhat-linux/4.3.0/../../../libgtkhtml-editor.so: undefined reference to `g_dgettext'
collect2: ld returned 1 exit status

It appears that Evolution is using gtkhtml3, which relies on a glib function "d_gettext" that was only added in glib 2.18 (see http://library.gnome.org/devel/glib/stable/glib-I18N.html#g-dgettext ), but I still had the Fedora 9 glib 2.16 installed.  To avoid this, gtkhtml3-3.24.0-1.fc10.i386 should require glib2 >= 2.18 or something equivalent.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. On Fedora 9, install the listed gtkhtml3 and glib2 packages and all other build requirements of evolution-2.24.0-3.fc10.src.rpm .
2. rpmbuild --rebuild evolution-2.24.0-3.fc10.src.rpm

Actual results:
Build error shown above.

Expected results:
An RPM dependency clues me in that I shouldn't be using glib2-2.16.6-1.fc9.i386.
Comment 1 Matthew Barnes 2008-10-21 12:17:08 EDT
Hmm, that's strange.  GtkHtml uses dgettext(), not g_dgettext().
Not sure why it would be referencing a function it doesn't use.

Before I bump the requirement and close the bug, I'd like to try to understand why this is happening.

CC'ing mclasen for his thoughts.
Comment 2 Bug Zapper 2008-11-25 23:01:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 3 Matthew Barnes 2009-01-27 12:28:45 EST
The Rawhide version of GtkHtml requires GTK+ 2.14 these days, which in turn requires GLib >= 2.17.x, so this should be resolved now.

Note You need to log in before you can comment on or make changes to this bug.