Bug 467686 - [PATCH] Fix rhel5 fs.sh fuser parsing
[PATCH] Fix rhel5 fs.sh fuser parsing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 05:01 EDT by Simone Gotti
Modified: 2009-04-16 18:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix fuser parsing in fs.sh (should also be applied to clusterfs.sh and netfs.sh) (473 bytes, patch)
2008-10-20 05:03 EDT, Simone Gotti
no flags Details | Diff

  None (edit)
Description Simone Gotti 2008-10-20 05:01:24 EDT
Description of problem:

fuser from rhel5 has different output respect the one from rhel4 so fs.sh needs a little change.

Looks like the 2 differences are:

*) mountpoint has an ending colon
*) Everything except the pid file is printed to sdterr instead of stdout


Example:

RHEL4:

[root@node01-rhel4 mnt]# fuser -vm /mnt/

                     USER        PID ACCESS COMMAND
/mnt/                root       8398 ..c..  bash


[root@node01-rhel4 mnt]# fuser -vm /mnt/ 2>/dev/null 

                     USER        PID ACCESS COMMAND
/mnt/                root       8398 ..c..  bash



rhel5:

[root@node01-rhel5 mnt]# fuser -vm /mnt/

                     USER        PID ACCESS COMMAND
/mnt/:               root      24128 ..c.. bash


[root@node01-rhel5 mnt]# fuser -vm /mnt/ 2>/dev/null 
 24128


Attached a little patch that should fix the fuser parsing in rhel5 rgmanager fs.sh. Probably the same patch should also be applied to clusterfs.sh and netfs.sh.
Comment 1 Simone Gotti 2008-10-20 05:03:18 EDT
Created attachment 320854 [details]
Fix fuser parsing in fs.sh (should also be applied to clusterfs.sh and netfs.sh)
Comment 2 Lon Hohberger 2008-10-20 13:10:50 EDT
Pushed.
Comment 3 Chris Feist 2008-10-20 15:16:36 EDT
Setting flags for inclusion.
Comment 10 errata-xmlrpc 2009-01-20 15:56:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0101.html

Note You need to log in before you can comment on or make changes to this bug.