Bug 467760 - nfs installs fail
nfs installs fail
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 15:14 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 21:53:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file (1.66 KB, text/plain)
2008-10-20 20:20 EDT, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2008-10-20 15:14:58 EDT
when I tried an nfs install today, it claimed the mount failed, even though the server side says..

Oct 20 14:13:58 gelk mountd[32555]: authenticated mount request from 192.168.42.12:926 for /mnt/data/mirror/rawhide/x86_64/images (/mnt/data/mirror)

There's a bunch of networkmanager spew on tty3, but nothing else interesting..

photo of spew is at http://davej.fedorapeople.org/dsc02030.jpg
Comment 1 David Cantrell 2008-10-20 17:06:04 EDT
What kind of network device are you using?

How did you bring up the installer (boot command line arguments?, static or dhcp network configuration?, sacrifice any animals?, if so how many?, and so on)?
Comment 2 Dave Jones 2008-10-20 20:19:53 EDT
I pxe booted, and used the kickstart file attached.

it uses plain gigabit ethernet & dhcp.
Comment 3 Dave Jones 2008-10-20 20:20:31 EDT
Created attachment 320948 [details]
kickstart file
Comment 4 David Cantrell 2008-10-20 21:24:39 EDT
What ks= boot parameter did you use?
Comment 5 David Cantrell 2008-10-24 21:50:56 EDT
OK, I've tried to reproduce this using today's tree and the upcoming anaconda that will land in rawhide tonight (11.4.1.51).  I cannot get it to hang while trying to do an NFS kickstart install.  It's going along just fine.

Can you try once anaconda-11.4.1.51-1 is in rawhide?
Comment 6 David Cantrell 2008-10-27 21:40:11 EDT
Using your kickstart file, I can't recreate this with rawhide.
Comment 7 Dave Jones 2008-10-31 16:43:17 EDT
the --opts=nfsvers=3,tcp is confusing it.

I just found on tty2 --

no stage2- given, assuming nfs:gelk:/mnt/data/mirror/rawhide/x86_64/:nfsvers=3,tcp/images/install.img

Shockingly, this doesn't work :)
Comment 8 David Cantrell 2008-10-31 23:05:51 EDT
Good times.  We now handle mount options elsewhere.  This was leftover code from before the mounting change-a-roo in isys.

Fixed in commit b31fb04b0c80dc849102baac18115223573d3ac7:

diff --git a/loader/nfsinstall.c b/loader/nfsinstall.c
index 1e8a530..9a61cad 100644
--- a/loader/nfsinstall.c
+++ b/loader/nfsinstall.c
@@ -345,16 +345,9 @@ void setKickstartNfs(struct loaderData_s * loaderData, int argc,
 
     substr = strstr(dir, ".img");
     if (!substr || (substr && *(substr+4) != '\0')) {
-        if (mountOpts) {
-            if (asprintf(&(loaderData->instRepo), "nfs:%s:%s:%s", host, dir, mountOpts) == -1) {
-                logMessage(CRITICAL, "%s: %d: %m", __func__, __LINE__);
-                abort();
-            }
-        } else {
-            if (asprintf(&(loaderData->instRepo), "nfs:%s:%s", host, dir) == -1) {
-                logMessage(CRITICAL, "%s: %d: %m", __func__, __LINE__);
-                abort();
-            }
+        if (asprintf(&(loaderData->instRepo), "nfs:%s:%s", host, dir) == -1) {
+            logMessage(CRITICAL, "%s: %d: %m", __func__, __LINE__);
+            abort();
         }
 
         logMessage(INFO, "results of nfs, host is %s, dir is %s, opts are '%s'",
Comment 9 Dave Jones 2008-11-07 21:53:12 EST
yep, tested today, all is good.

Note You need to log in before you can comment on or make changes to this bug.