Bug 467774 - firstboot leaves wrong virtual console active after reconfiguring system
firstboot leaves wrong virtual console active after reconfiguring system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 16:29 EDT by Ed Swierk
Modified: 2008-10-23 15:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 15:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Swierk 2008-10-20 16:29:17 EDT
Description of problem:

When firstboot runs in reconfigure mode, it leaves the wrong virtual console active, so the screen shows gibberish until you press Ctrl-Alt-F7 to switch to X.


Version-Release number of selected component (if applicable):

1.97-1.fc9


How reproducible:

Every time


Steps to Reproduce:
1. On an already-configured system with X installed and runlevel 5 as the default, set firstboot to run on the next reboot:
   touch /etc/reconfigSys
   rm -f /etc/sysconfig/firstboot
   chkconfig firstboot on
2. Reboot the system
3. Walk through the firstboot steps
4. When firstboot exits, notice the screen shows junk, until you press Ctrl-Alt-F7 to switch to the X console
Comment 1 Chris Lumens 2008-10-23 15:38:09 EDT
This is fixed in the current release of firstboot in rawhide, which means it'll also be fixed in F10.

Note You need to log in before you can comment on or make changes to this bug.