Bug 467801 - Formatting of disk partitions is ON by default
Formatting of disk partitions is ON by default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 19:17 EDT by Vladimir Ivanovic
Modified: 2008-10-22 00:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 16:56:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Ivanovic 2008-10-20 19:17:37 EDT
Description of problem:
During the disk/partition selection phase of the install, not all disks are visible---only the first three items in the combo box are visible---and they are by default set to be formatted. This is wrong, wrong, wrong. I suffered an inadvertently formatted disk in F9, losing ALL the data on that disk, and the current setup is much safer, but I still nearly inadvertently formatted some disks, the ones hidden in the combo box.

The default must be NOT TO FORMAT. 

Version-Release number of selected component (if applicable):
F10-Beat

How reproducible:
Run the F10 install script.

Steps to Reproduce:
1. Insert CD into drive.
2. Choose to install a new system.
3. Answer the questions as they come up.
  
Actual results:
Special effort must be made to realize that there may be more than 3 disks involved in the formatting phase, disks that are not immediately visible.

Expected results:
All disks are obvious before formatting is committed.

Additional info:

I do not thinks it is safe to rely on the formatting flag being on and it being caught in subsequent steps. The inadvertent condition should not be allowed to arise in the first place.
Comment 1 David Cantrell 2008-10-21 16:56:25 EDT
There is a scroll bar on the right side of the drive list you are referring about.  Scroll down to see the other disks that are selected.

While I hate that you lost data, the fact of the matter is you ran the Fedora installation program.  As an installation program, we assume that most (but not all) of the users will be formatting their disks and installing Fedora since that's really the only thing the installation program *does*.  This reason is why the default is to select all usable drives by default (as seen by the check boxes next to the drive names, use the scroll bar to see the whole list) and the partitioning policy (combo box near the top of the screen) is set to "Remove all Linux partitions on this system" which does exactly that and then creates new Fedora partitions for you.

In that same combo box, you can select "Custom" to completely bypass any automatic partitioning and go directly to the custom partitioning screen.
Comment 2 Vladimir Ivanovic 2008-10-21 22:44:21 EDT
(In reply to comment #1)

I know about the scrollbar. That's how I discovered that all my disks were about to be formatted. The point is that this requires user action to become aware that you are about to lose all your data.

Why are non-system disks formatted by default? Why delete user data if you're never going to use that disk? This is guarantees that some users are going to lose. Data loss is the worst kind of bug.

I generally use "Custom" or its equivalent. The point is that the default is to delete all user data. 

I don't understand why you don't agree that if the default is to erase all user data, that this is bad---very, very bad.

Also, I am saddened that you closed this bug. As a person who has managed SQA organizations and as a product manager immersed in quality issues at the tail end of a development cycle, I would never have closed this bug. That's (a) insulting to me and (b) dangerous to your customers.
Comment 3 David Cantrell 2008-10-22 00:07:11 EDT
(In reply to comment #2)
> (In reply to comment #1)
> 
> I know about the scrollbar. That's how I discovered that all my disks were
> about to be formatted. The point is that this requires user action to become
> aware that you are about to lose all your data.

And you still clicked Next?

> Why are non-system disks formatted by default? Why delete user data if you're
> never going to use that disk? This is guarantees that some users are going to
> lose. Data loss is the worst kind of bug.

There's no way for us to tell what disks hold what information on a target system, this is why the default has always been to select all disks, but only remove Linux partitions and create new partitions for Fedora.  If you have any other non-Linux partitions on your disks, we ignore those.

This presents issues for people wanting multiple Linux operating systems on one computer, but those users typically do Custom partitioning anyway.

> I generally use "Custom" or its equivalent. The point is that the default is to
> delete all user data.

This is made abundantly clear to the user in the program as well as all documentation on installation in both Fedora and RHEL.  Additionally, users are *ALWAYS* advised to backup their data before installation.

> I don't understand why you don't agree that if the default is to erase all user
> data, that this is bad---very, very bad.

This has been our default partitioning scheme for as long as Fedora has existed and you are the first person to complain about it in this capacity.

> Also, I am saddened that you closed this bug. As a person who has managed SQA
> organizations and as a product manager immersed in quality issues at the tail
> end of a development cycle, I would never have closed this bug. That's (a)
> insulting to me and (b) dangerous to your customers.

It was not meant to be insulting, it's just that you raised an issue that is not a bug.  You have asked for the default partitioning scheme in the installer to change to not formatting disks by default.  Installers can't work that way.  We have to claim some disk space, otherwise we can't do anything.  What we have currently is the result of years of observing our users and catering to the most common use cases.  There are plenty of partitioning methods available in anaconda (more so than other non-open operating systems) that I really don't see why we should change what we are doing now.

Still, selecting Custom partitioning makes all of this a non-issue, so I still fail to see what the problem is.

Note You need to log in before you can comment on or make changes to this bug.