Bug 467840 - anaconda RuntimeError
anaconda RuntimeError
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
other Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 03:53 EDT by Jean Lucasse
Modified: 2008-10-21 23:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 17:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda error detail (74.31 KB, text/plain)
2008-10-21 03:53 EDT, Jean Lucasse
no flags Details

  None (edit)
Description Jean Lucasse 2008-10-21 03:53:54 EDT
Created attachment 320989 [details]
anaconda error detail

Description of problem:
after creating custom partitions, Exception Occurred and locked up the machine:
anaconda 11.4.1.40 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 103, in execWithCapture
   raise RuntimeError, "Error running " + command + ":" +msg
  File "/usr/lib/anaconda/iutil.py", line 476, in isMactel
   ["dmidecode","-s","system-manufacturer"])
  File "/usr/lib/anaconda/partitions.py", line 1183, in sanityCheckAllRequests
   if iutil.isMactel():
  File "/usr/lib/anaconda/iw/partition_gui.py", line 637, in getNext
   (errors, warnings) = self.partitions.sanityCheckAllRequests(self.diskset)
    .......

    Could not see any more details, since the computer locked up

  After trying to install again, this time with default partitioning, I got
  the following error detail in the attachment below. I was able to save the
  details on a usb stick



Version-Release number of selected component (if applicable): fedora 10 beta


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Jones 2008-10-21 10:51:37 EDT
If you go to tty2 and run "dmidecode -s system-manufacturer", what happens?
Comment 2 Chris Lumens 2008-10-21 17:57:32 EDT
The following errors in your exception indicate problems with the media, kernel drivers, or your hardware.  Did you run media check before continuing with the install?

<6>sr 2:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
<6>sr 2:0:0:0: [sr0] Sense Key : Medium Error [current] 
<6>sr 2:0:0:0: [sr0] ASC=0x10 <<vendor>> ASCQ=0x90
<3>end_request: I/O error, dev sr0, sector 6848344
Comment 3 Jean Lucasse 2008-10-21 23:29:13 EDT
(In reply to comment #1)
> If you go to tty2 and run "dmidecode -s system-manufacturer", what happens?

the result is : Hewlett-Packard
Comment 4 Jean Lucasse 2008-10-21 23:31:05 EDT
(In reply to comment #2)
> The following errors in your exception indicate problems with the media, kernel
> drivers, or your hardware.  Did you run media check before continuing with the
> install?
> <6>sr 2:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
> <6>sr 2:0:0:0: [sr0] Sense Key : Medium Error [current] 
> <6>sr 2:0:0:0: [sr0] ASC=0x10 <<vendor>> ASCQ=0x90
> <3>end_request: I/O error, dev sr0, sector 6848344

    The media check was done before installing, it reported no errors

Note You need to log in before you can comment on or make changes to this bug.