Bug 467858 - Error installing coreutils: /var/tmp/rpm-tmp.73408: line 4: find: command not found
Error installing coreutils: /var/tmp/rpm-tmp.73408: line 4: find: command not...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coreutils (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 07:41 EDT by Alexander Todorov
Modified: 2009-01-20 16:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:42:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-21 07:41:40 EDT
Description of problem:
preinstall scriptlet of coreutils fails because it uses the find command which is not installed.

Version-Release number of selected component (if applicable):
coreutils-5.97-18

How reproducible:
Always

Steps to Reproduce:
1. Perform a default install
%packages
@admin-tools
@base
@base-x
@core
@dialup
@editors
@games
@gnome-desktop
@graphical-internet
@graphics
@java
@office
@printing
@sound-and-video
@text-internet
busybox
comps-extras
cracklib-dicts
gnome-mime-data
kernel-headers
nash
rmt
tzdata


2. Inspect install.log for errors

  
Actual results:
Installing coreutils-5.97-18.el5.ia64
/var/tmp/rpm-tmp.73408: line 4: find: command not found


Expected results:
No rpm errors

Additional info:
findutils which provides find is installed 20 packages later.
Comment 1 Ondrej Vasik 2008-10-21 08:20:56 EDT
RHEL-5 coreutils.spec file contains:
Prereq: grep, findutils
Although Prereq is depricated, it should work as Requires: for this case. It looks like dependency resolver issue / circle dependency solved by ignoring PreReq 
... Anyway Requires(prep, pre) looks better - and maybe will solve that issue.

In Fedora both coreutils and findutils are on Exception list, therefore no requires for them are necessary.
Comment 9 errata-xmlrpc 2009-01-20 16:42:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0173.html

Note You need to log in before you can comment on or make changes to this bug.