Bug 467859 - virt-install --prompt ...doesn't prompt
virt-install --prompt ...doesn't prompt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 07:53 EDT by Chris Snook
Modified: 2009-10-05 10:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 10:24:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2008-10-21 07:53:00 EDT
Description of problem:
The --prompt flag to virt-install is ignored.

Version-Release number of selected component (if applicable):
python-virtinst-0.400.0-2.fc10.noarch

How reproducible:
100%

Steps to Reproduce:
1. virt-install --prompt
  
Actual results:
[root@ada ~]# virt-install --prompt
ERROR    A name is required for the virtual machine.

Expected results:
virt-install prompts when given the --prompt option

Additional info:
Giving a name just makes it move down the list.  The --prompt flag is still completely ignored:

[root@ada ~]# virt-install --prompt -n foo
ERROR    Memory amount is required for the virtual machine.
Comment 1 Cole Robinson 2008-10-21 10:01:34 EDT
Yeah, that's kind of funny :) Originally we ripped out all the major prompts (What name, how much mem, etc.) and only left critical boolean prompts (If fully allocated this sparse disk will eat your brain, are you sure?). At a later time the --prompt flag was added to prevent any prompting from being the default.

I agree we should use the original prompts if --prompt is specified, this was largely poor planning on my part. Won't be done for F10 though.
Comment 2 Chris Snook 2008-10-21 10:22:10 EDT
Understood.  It's not a huge problem, but it's annoying.  If we're going to release F10 in this state, we should fix the man page and the virt-install -h output.
Comment 3 Bug Zapper 2008-11-25 23:04:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Cole Robinson 2009-03-23 16:38:24 EDT
Revived upstream, though it is opt in behavior with the --prompt flag. Error messages try to steer users in that direction if they leave of something simple like --name.

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/cda75d189b9c
Comment 5 Cole Robinson 2009-10-05 10:24:16 EDT
Since this would be a pretty substantial backport, it won't be hitting F-10 or F-11 unless we rebase (which isn't likely). So closing as RAWHIDE where this is currently fixed (F-12 will have it as well).

Note You need to log in before you can comment on or make changes to this bug.