Bug 467866 - Redhat Software Updater Crash
Redhat Software Updater Crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.3
i386 Linux
medium Severity urgent
: rc
: ---
Assigned To: Pradeep Kilambi
Jan Hutař
:
Depends On:
Blocks: 508737
  Show dependency treegraph
 
Reported: 2008-10-21 08:36 EDT by Surendhar
Modified: 2010-03-14 17:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
previously, yum-rhn-plugin did not allow for situations where the update agent sent a request to a Red Hat Network server, but received no response within its timeout interval. This would generate an unhandled exception that would crash the update agent. Now, if the update agent does not receive a timely response from an RHN server, it will present the user with an error message that says: "Server Unavailable. Please try later".
Story Points: ---
Clone Of:
: 508737 (view as bug list)
Environment:
Last Closed: 2009-09-02 07:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error Msg (2.60 KB, text/plain)
2008-10-21 08:45 EDT, Surendhar
no flags Details
Up2date Error Log File (46.57 KB, application/octet-stream)
2008-10-21 08:50 EDT, Surendhar
no flags Details

  None (edit)
Description Surendhar 2008-10-21 08:36:18 EDT
Description of problem:

When i tried to update the Software Updater it show an error.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Amy Owens 2008-10-21 08:43:17 EDT
can we get some more info here? what was the error?
Comment 2 Surendhar 2008-10-21 08:45:23 EDT
Created attachment 321010 [details]
Error Msg

This error occured when i click the Software Updater. I have copied the entier error message.
Comment 3 Surendhar 2008-10-21 08:50:08 EDT
Created attachment 321011 [details]
Up2date Error Log File
Comment 5 Surendhar 2008-11-10 06:18:59 EST
Still This issue has not been resolved for me.

Can anyone suggest how to fix this issue?
Comment 6 Surendhar 2008-11-10 06:19:59 EST
yum update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 199, in getOptionsConfig
    errorlevel=opts.errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 134, in doConfigSetup
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 75, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 211, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 178, in login
    li = server.up2date.login(systemId)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 194, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 319, in _request
    request, verbose=self._verbose)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 170, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 697, in send_http
    self._connection.connect()
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 226, in connect
    response = HTTPConnection.getresponse(self)
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 124, in getresponse
    response.begin()
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 199, in begin
    HTTPResponse.begin(self)
  File "/usr/lib/python2.4/httplib.py", line 336, in begin
    version, status, reason = self._read_status()
  File "/usr/lib/python2.4/httplib.py", line 300, in _read_status
    raise BadStatusLine(line)
httplib.BadStatusLine
[root@Texflow-Test ~]# 


This is the error i got.
Comment 7 John Matthews 2008-11-10 11:07:07 EST
The error reported here is due to intermittent timeout issues with RHN hosted.  We will update the client to catch this exception and print an easier to understand error message.
Example:
  "Server Unavailable. Please try later"

This work will be proposed for RHEL 5.4.
Comment 33 Ruediger Landmann 2009-08-27 21:51:26 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
previously, yum-rhn-plugin did not allow for situations where the
update agent sent a request to a Red Hat Network server, but received no 
response within its timeout interval. This would generate an unhandled
exception that would crash the update agent. Now, if the update agent
does not receive a timely response from an RHN server, it will present
the user with an error message that says: "Server Unavailable. Please try 
later".
Comment 34 errata-xmlrpc 2009-09-02 07:22:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1355.html

Note You need to log in before you can comment on or make changes to this bug.