Bug 467874 - liferea segfaults because of memory corruption
liferea segfaults because of memory corruption
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 09:24 EDT by Tom Georgoulias
Modified: 2008-12-08 08:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 08:00:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Georgoulias 2008-10-21 09:24:18 EDT
Description of problem:

Liferea segfaults because of memory corruption.

Version-Release number of selected component (if applicable):
liferea-1.4.18-1.fc9.i386

(also happens on my Fedora 8 system)

How reproducible:

Everytime

Steps to Reproduce:
1. Start liferea from terminal
2. Let it run for a while
  
Actual results:

After liferea crashes, this backtrace remains in the terminal window.

*** glibc detected *** /usr/bin/liferea-bin: malloc(): memory corruption (fast): 0x09d010d8 ***
======= Backtrace: =========
/lib/libc.so.6[0xb0a874]
/lib/libc.so.6[0xb0d8d6]
/lib/libc.so.6(__libc_calloc+0xef)[0xb0ea0f]
/lib/libglib-2.0.so.0(g_malloc0+0x3c)[0x5403ac]
/lib/libglib-2.0.so.0(g_get_charset+0x1a4)[0x5694c4]
/lib/libglib-2.0.so.0(g_strsignal+0x36)[0x559276]
/usr/bin/liferea-bin[0x807412c]
[0x110400]
/lib/libc.so.6(strcat+0x162)[0xb11fe2]
/usr/bin/liferea-bin(NetIO+0x820)[0x8077840]
/usr/bin/liferea-bin(DownloadFeed+0x126)[0x8078eb6]
/usr/bin/liferea-bin(network_process_request+0xdc)[0x806c6dc]
/usr/bin/liferea-bin[0x8072d40]
/usr/bin/liferea-bin[0x8073258]
/lib/libglib-2.0.so.0[0x5623df]
/lib/libpthread.so.0[0xc4032f]
/lib/libc.so.6(clone+0x5e)[0xb7b20e]
======= Memory map: ========
00110000-00111000 r-xp 00110000 00:00 0          [vdso]
00111000-0020e000 r-xp 00000000 fd:00 32934      /usr/lib/libX11.so.6.2.0
0020e000-00212000 rw-p 000fc000 fd:00 32934      /usr/lib/libX11.so.6.2.0
00212000-00221000 r-xp 00000000 fd:00 32950      /usr/lib/libXext.so.6.4.0
00221000-00222000 rw-p 0000e000 fd:00 32950      /usr/lib/libXext.so.6.4.0
00222000-0022c000 r-xp 00000000 fd:00 393336     /lib/libnss_files-2.8.so
0022c000-0022d000 r--p 0000a000 fd:00 393336     /lib/libnss_files-2.8.so
0022d000-0022e000 rw-p 0000b000 fd:00 393336     /lib/libnss_files-2.8.so
0022e000-0023c000 r-xp 00000000 fd:00 462071     /usr/lib/gtk-2.0/modules/libgnomebreakpad.so
0023c000-0023d000 rw-p 0000d000 fd:00 462071     /usr/lib/gtk-2.0/modules/libgnomebreakpad.so
0023f000-002ca000 r-xp 00000000 fd:00 32892      /usr/lib/libfreetype.so.6.3.16
002ca000-002ce000 rw-p 0008a000 fd:00 32892      /usr/lib/libfreetype.so.6.3.16
002d0000-002fe000 r-xp 00000000 fd:00 32895      /usr/lib/libfontconfig.so.1.3.0
002fe000-002ff000 rw-p 0002e000 fd:00 32895      /usr/lib/libfontconfig.so.1.3.0
00301000-00328000 r-xp 00000000 fd:00 340645     /usr/lib/libpng12.so.0.29.0
00328000-00329000 rw-p 00026000 fd:00 340645     /usr/lib/libpng12.so.0.29.0
0032b000-00333000 r-xp 00000000 fd:00 32940      /usr/lib/libXrender.so.1.3.0
00333000-00334000 rw-p 00007000 fd:00 32940      /usr/lib/libXrender.so.1.3.0
00336000-00338000 r-xp 00000000 fd:00 32956      /usr/lib/libXcomposite.so.1.0.0
00338000-00339000 rw-p 00001000 fd:00 32956      /usr/lib/libXcomposite.so.1.0.0
0033b000-00367000 r-xp 00000000 fd:00 32946      /usr/lib/libpixman-1.so.0.10.0
00367000-00368000 rw-p 0002c000 fd:00 32946      /usr/lib/libpixman-1.so.0.10.0
00368000-0038d000 r-xp 00000000 fd:00 393489     /lib/libexpat.so.1.5.2
0038d000-0038f000 rw-p 00024000 fd:00 393489     /lib/libexpat.so.1.5.2
0038f000-00391000 r-xp 00000000 fd:00 550456     /usr/lib/liferea/liblinotiflibnotify.so
00391000-00392000 rw-p 00002000 fd:00 550456     /usr/lib/liferea/liblinotiflibnotify.so
00392000-00399000 r-xp 00000000 fd:00 340061     /usr/lib/libnotify.so.1.1.2
00399000-0039a000 rw-p 00006000 fd:00 340061     /usr/lib/libnotify.so.1.1.2
0039a000-003a8000 r-xp 00000000 fd:00 549008     /usr/lib/liferea/liblihtmlm.so
003a8000-003a9000 rw-p 0000d000 fd:00 549008     /usr/lib/liferea/liblihtmlm.so
003ac000-003af000 r-xp 00000000 fd:00 429926     /usr/lib/xulrunner-1.9/libxpcom.so
003af000-003b0000 rw-p 00003000 fd:00 429926     /usr/lib/xulrunner-1.9/libxpcom.so
003b0000-003b2000 r-xp 00000000 fd:00 336828     /usr/lib/gconv/UTF-16.so
003b2000-003b3000 r--p 00001000 fd:00 336828     /usr/lib/gconv/UTF-16.so
003b3000-003b4000 rw-p 00002000 fd:00 336828     /usr/lib/gconv/UTF-16.so
003b5000-003bd000 r-xp 00000000 fd:00 32952      /usr/lib/libXi.so.6.0.0
003bd000-003be000 rw-p 00007000 fd:00 32952      /usr/lib/libXi.so.6.0.0
003be000-003c7000 r-xp 00000000 fd:00 446100     /usr/lib/xulrunner-1.9/components/libdbusservice.so
003c7000-003c8000 rw-p 00009000 fd:00 446100     /usr/lib/xulrunner-1.9/components/libdbusservice.so
003cc000-003d2000 r-xp 00000000 fd:00 32953      /usr/lib/libXrandr.so.2.1.0
003d2000-003d3000 rw-p 00005000 fd:00 32953      /usr/lib/libXrandr.so.2.1.0
003d3000-003f9000 r-xp 00000000 fd:00 393509     /lib/libsmime3.so
003f9000-003
Liferea did receive signal 11 (Segmentation fault).


Expected results:


Additional info:
Comment 1 Tom Georgoulias 2008-10-22 12:53:20 EDT
As an experiment, I uninstalled flash-plugin-10.0.12.36-release from my computer.  I have not had this crash happen since that time, so it appears that flash causes these liferea memory corruption issues.
Comment 2 Fedora Update System 2008-10-22 18:55:28 EDT
liferea-1.4.20-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/liferea-1.4.20-3.fc9
Comment 3 Fedora Update System 2008-10-23 12:37:42 EDT
liferea-1.4.20-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update liferea'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9060
Comment 4 Fedora Update System 2008-10-23 16:50:56 EDT
liferea-1.4.20-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/liferea-1.4.20-4.fc9
Comment 5 Fedora Update System 2008-10-24 19:48:18 EDT
liferea-1.4.20-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update liferea'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9114
Comment 6 Fedora Update System 2008-11-25 20:35:52 EST
liferea-1.4.22d-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/liferea-1.4.22d-1.fc10
Comment 7 Fedora Update System 2008-11-25 20:36:06 EST
liferea-1.4.22d-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/liferea-1.4.22d-1.fc9
Comment 8 Fedora Update System 2008-11-26 21:09:43 EST
liferea-1.4.22d-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update liferea'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10445
Comment 9 Fedora Update System 2008-11-26 21:12:49 EST
liferea-1.4.22d-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update liferea'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10478
Comment 10 Fedora Update System 2008-12-08 08:00:36 EST
liferea-1.4.22d-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-12-08 08:02:02 EST
liferea-1.4.22d-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.