Bug 467900 - SELinux is preventing sendmail (system_mail_t) "read" to ./fips_enabled (sysctl_t)
SELinux is preventing sendmail (system_mail_t) "read" to ./fips_enabled (sysc...
Status: CLOSED DUPLICATE of bug 467720
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 12:17 EDT by Jakub Hrozek
Modified: 2008-10-21 14:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 14:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2008-10-21 12:17:58 EDT
Summary:

SELinux is preventing sendmail (system_mail_t) "read" to ./fips_enabled
(sysctl_t).

Detailed Description:

SELinux denied access requested by sendmail. It is not expected that this access
is required by sendmail and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for ./fips_enabled,

restorecon -v './fips_enabled'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:system_mail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:sysctl_t:s0
Target Objects                ./fips_enabled [ file ]
Source                        sendmail
Source Path                   /usr/sbin/sendmail.sendmail
Port                          <Unknown>
Host                          jarilo.englab.brq.redhat.com
Source RPM Packages           sendmail-8.13.8-2.el5
Target RPM Packages           
Policy RPM                    selinux-policy-2.4.6-165.el5
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     jarilo.englab.brq.redhat.com
Platform                      Linux jarilo.englab.brq.redhat.com 2.6.18-118.el5
                              #1 SMP Sat Oct 4 00:21:41 EDT 2008 i686 i686
Alert Count                   1
First Seen                    Tue 21 Oct 2008 05:53:41 PM CEST
Last Seen                     Tue 21 Oct 2008 05:53:41 PM CEST
Local ID                      9f4690a7-14bd-4fa7-8a21-c5d9fbf7777f
Line Numbers                  

Raw Audit Messages            

host=jarilo.englab.brq.redhat.com type=AVC msg=audit(1224604421.229:51): avc:  denied  { read } for  pid=5005 comm="sendmail" name="fips_enabled" dev=proc ino=-268435032 scontext=system_u:system_r:system_mail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sysctl_t:s0 tclass=file

host=jarilo.englab.brq.redhat.com type=SYSCALL msg=audit(1224604421.229:51): arch=40000003 syscall=5 success=no exit=-13 a0=a228a3 a1=0 a2=1 a3=a5e980 items=0 ppid=4969 pid=5005 auid=4294967295 uid=51 gid=51 euid=51 suid=51 fsuid=51 egid=51 sgid=51 fsgid=51 tty=(none) ses=4294967295 comm="sendmail" exe="/usr/sbin/sendmail.sendmail" subj=system_u:system_r:system_mail_t:s0-s0:c0.c1023 key=(null)

-----
Additional Information:
# ll -Z /proc/sys/crypto/fips_enabled
-r--r--r--  root root system_u:object_r:sysctl_t:s0    /proc/sys/crypto/fips_enabled
# sesearch -a -s system_mail_t -t sysctl_t --class file
(nothing)
Comment 1 Daniel Walsh 2008-10-21 14:03:57 EDT

*** This bug has been marked as a duplicate of bug 467720 ***

Note You need to log in before you can comment on or make changes to this bug.