Bug 467903 - SELinux is preventing ssh-keygen (ssh_keygen_t) "read" to ./fips_enabled (sysctl_t).
SELinux is preventing ssh-keygen (ssh_keygen_t) "read" to ./fips_enabled (sys...
Status: CLOSED DUPLICATE of bug 467720
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 12:22 EDT by Jakub Hrozek
Modified: 2008-10-21 14:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 14:03:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2008-10-21 12:22:13 EDT
Detailed Description:

SELinux denied access requested by ssh-keygen. It is not expected that this
access is required by ssh-keygen and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for ./fips_enabled,

restorecon -v './fips_enabled'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:ssh_keygen_t:s0
Target Context                system_u:object_r:sysctl_t:s0
Target Objects                ./fips_enabled [ file ]
Source                        ssh-keygen
Source Path                   /usr/bin/ssh-keygen
Port                          <Unknown>
Host                          jarilo.englab.brq.redhat.com
Source RPM Packages           openssh-4.3p2-29.el5
Target RPM Packages
Policy RPM                    selinux-policy-2.4.6-165.el5
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     jarilo.englab.brq.redhat.com
Platform                      Linux jarilo.englab.brq.redhat.com 2.6.18-118.el5
                              #1 SMP Sat Oct 4 00:21:41 EDT 2008 i686 i686
Alert Count                   3
First Seen                    Tue 21 Oct 2008 04:48:35 PM CEST
Last Seen                     Tue 21 Oct 2008 04:48:37 PM CEST
Local ID                      01193bc1-ee8e-489b-80db-68e97d9a577b
Line Numbers

Raw Audit Messages

host=jarilo.englab.brq.redhat.com type=AVC msg=audit(1224600517.28:10): avc:  denied  { read } for  pid=2702 comm="ssh-keygen" name="fips_enabled" dev=proc
ino=-268435032 scontext=system_u:system_r:ssh_keygen_t:s0 tcontext=system_u:object_r:sysctl_t:s0 tclass=file

host=jarilo.englab.brq.redhat.com type=SYSCALL msg=audit(1224600517.28:10): arch=40000003 syscall=5 success=no exit=-13 a0=bdd8a3 a1=0 a2=93bcc8 a3=bf90aec4
 items=0 ppid=2686 pid=2702 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ssh-keygen" exe="/usr/bi
n/ssh-keygen" subj=system_u:system_r:ssh_keygen_t:s0 key=(null)
Comment 1 Daniel Walsh 2008-10-21 14:03:21 EDT

*** This bug has been marked as a duplicate of bug 467720 ***

Note You need to log in before you can comment on or make changes to this bug.