Bug 467928 - Need newer igb driver to support Intel 82576 Gigabit Ethernet Controller (Kawela)
Need newer igb driver to support Intel 82576 Gigabit Ethernet Controller (Kaw...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 14:20 EDT by Charlotte Richardson
Modified: 2008-10-21 17:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 17:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlotte Richardson 2008-10-21 14:20:46 EDT
Description of problem:
The igb driver in RHEL5.2, igb-1.0.8-k2, does not support this embedded gigabit ethernet controller (Kawela chipset). The new igb driver which can be downloaded from the Intel website, igb-1.2.44.9, supports it. The PCI vendor ID of the new NIC is 0x8086 (of course) and the device ID is 0x10C9. The new driver calls this device E1000_DEV_ID_82576. We can load the driver from a driver disk during initial installation on the systems with this NIC but it is a major nuisance.


Version-Release number of selected component (if applicable):
igb-1.0.8-k2

How reproducible:
100%


Steps to Reproduce:
1. Attempt to install RHEL5.2 over the network using RHEL5.2 DVD.

  
Actual results:
The embedded ethernet devices are not claimed by the igb driver, so the installation cannot be done over the network.


Expected results:
Newer driver would claim the devices allowing the network installation to work.


Additional info:
Comment 1 Charlotte Richardson 2008-10-21 15:42:35 EDT
Looks like support *IS* present in 5.3_Alpha.
Comment 2 Charlotte Richardson 2008-10-21 17:59:34 EDT
Confirmed that this NIC is supported in the driver version in RHEL5.3_Alpha, so closing this Bug as RHEL5.3 meets our timeframe.

Note You need to log in before you can comment on or make changes to this bug.