Bug 467984 - kdesdk-utils should not depends on kdelibs etc
kdesdk-utils should not depends on kdelibs etc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 00:36 EDT by Jens Petersen
Modified: 2008-10-23 12:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:41:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-10-22 00:36:27 EDT
Description of problem:
Installing kdesdk-utils pulls in a bunch of kde packages which it should not depends on AFAIK.

Steps to Reproduce:
1. yum install kdesdk-utils
2. inspect source for po2xml etc
3. look at koji build log
  
Actual results:
1. pulls in kdelibs and bunch of other core kde packages
2. does not include any kde include files
3. links explicitly to /usr/lib/kde4/devel/libkdecore.so
http://kojipkgs.fedoraproject.org/packages/kdesdk/4.1.2/2.fc10/data/logs/i386/build.log

Expected results:
1. not to pull in megabytes of kde packages
3. not to link to libkdecore

Additional info:
The debian package does not depend on kde:
http://packages.debian.org/experimental/poxml
This is also affects F9.
Comment 1 Rex Dieter 2008-10-22 09:08:26 EDT
Confirmed.  ugh.

Debian strips out a lot of extraneous lib linkage and deps (upstreamed for kde-4.2.0), looks like we may have some surgery to do too.
Comment 2 Fedora Update System 2008-10-22 12:13:16 EDT
kdesdk-4.1.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kdesdk-4.1.2-3.fc9
Comment 3 Fedora Update System 2008-10-23 12:41:38 EDT
kdesdk-4.1.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.