Bug 467996 - anaconda in rhel5 doesn't support md raid10
anaconda in rhel5 doesn't support md raid10
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Joel Andres Granados
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 04:28 EDT by Tuomo Soini
Modified: 2009-09-02 05:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:55:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
md raid10 support for rhel5 anaconda (4.57 KB, patch)
2008-10-22 04:48 EDT, Tuomo Soini
no flags Details | Diff
md raid10 support for rhel5 anaconda (5.27 KB, patch)
2008-10-29 15:27 EDT, Tuomo Soini
no flags Details | Diff
optional patch to use --laoyout=f2 with md raid10 instead of default (644 bytes, patch)
2008-10-29 15:41 EDT, Tuomo Soini
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1306 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2009-09-01 06:20:11 EDT

  None (edit)
Description Tuomo Soini 2008-10-22 04:28:45 EDT
anaconda in rhel5 doesn't support raid10 with md while all tools do.

Attached is patch against anaconda-11.1.2.145 which does add raid10 support (backported from rawhide).
Comment 1 Tuomo Soini 2008-10-22 04:48:51 EDT
Created attachment 321127 [details]
md raid10 support for rhel5 anaconda
Comment 2 Tuomo Soini 2008-10-22 04:51:57 EDT
Oh. there was one fix over rawhide version. I fixed minimum raid members to correct value (2) from fedora anaconda's 4. md raid10 supports 2 and 3 disks (raid1e) configurations too.
Comment 3 Tuomo Soini 2008-10-29 15:24:09 EDT
Hey, this feature is really missing from 5.3 beta. Only dm-raid raid10 is supported.

Updated patch for some fixes I found from old anaconda raid10 support bugzilla entry.
Comment 4 Tuomo Soini 2008-10-29 15:27:51 EDT
Created attachment 321856 [details]
md raid10 support for rhel5 anaconda
Comment 5 Denise Dumas 2008-10-29 15:35:51 EDT
Thanks, Tuomo. The 5.3 schedule doesn't let us add this support (Beta is already frozen) but will look for 5.4.
Comment 6 Tuomo Soini 2008-10-29 15:41:16 EDT
Created attachment 321861 [details]
optional patch to use --laoyout=f2 with md raid10 instead of default
Comment 7 Tuomo Soini 2008-10-29 15:45:01 EDT
Notice bug #468379 need to be addresses for optional patch.
Comment 8 RHEL Product and Program Management 2009-02-03 18:15:22 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Martin Gracik 2009-02-24 04:38:26 EST
Added support for creating a mdraid 10 array during install to anaconda for RHEL5. Works for 2 or more devices.
Should be available in version 5.4.
Comment 11 Martin Gracik 2009-02-24 04:52:40 EST
CORRECTION:
Will be available in anaconda version 11.1.2.169
Comment 13 Alexander Todorov 2009-07-06 11:09:23 EDT
anaconda GUI 0701.0 tree:
create raid10 and mount on /home - PASS
assign mount point /home on pre-existing raid10, no format - PASS
raid10 for non rootfs - PASS
raid10 for root fs - PASS
Comment 14 Alexander Todorov 2009-07-06 11:12:08 EDT
Martin,
based on comment #9 it looks like this bug addresses only the GUI part of anaconda. Can you confirm?
Comment 15 Jan Stodola 2009-07-09 11:03:16 EDT
tree 20090708, anaconda-11.1.2.184-1, arch: ppc
GUI installation:
* raid10 for root fs - OK
* raid10 for /usr - OK
* using pre-existing raid10 for root fs and /usr - OK
kickstart installation:
* raid10 for root fs - OK
* raid10 for /usr - OK
Comment 16 Joel Andres Granados 2009-07-13 07:50:18 EDT
atodorov:
Yes, this is only for GUI.  We are trying to move away from text mode support.
Comment 17 Alexander Todorov 2009-07-13 08:04:34 EDT
Thanks Joel. Moving to VERIFIED as per comment #13 and comment #15. GUI and Kickstart tested and confirmed to work.
Comment 19 errata-xmlrpc 2009-09-02 05:55:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.