Bug 468010 - python stacktrace in /var/log/messages
python stacktrace in /var/log/messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal-cups-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 07:00 EDT by Mads Kiilerich
Modified: 2008-10-23 07:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 07:55:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-10-22 07:00:27 EDT
Description of problem:

On boot I get in /var/log/messages
Oct 22 12:01:39 dev-mk hal_lpadmin: File "/usr/libexec/hal_lpadmin", line 476, in main#012    h = HalLpAdmin()
Oct 22 12:01:39 dev-mk hal_lpadmin: File "/usr/libexec/hal_lpadmin", line 451, in __init__#012    self.removePrinter()
Oct 22 12:01:39 dev-mk hal_lpadmin: File "/usr/libexec/hal_lpadmin", line 466, in removePrinter#012    printer.remove()
Oct 22 12:01:39 dev-mk hal_lpadmin: File "/usr/libexec/hal_lpadmin", line 370, in remove#012    make = self.properties["printer.vendor"]
Oct 22 12:01:39 dev-mk hal_lpadmin: KeyError: 'printer.vendor'

It might be the fix for Bug 466485 which doesn't work as intended.

Version-Release number of selected component (if applicable):

hal-cups-utils-0.6.17-2.fc10.i386
Comment 1 Tim Waugh 2008-10-22 10:43:54 EDT
Please try hal-cups-utils-0.6.17-3.fc10.
Comment 2 Mads Kiilerich 2008-10-23 07:55:48 EDT
Yes, apparently fixed, thanks, closing

Note You need to log in before you can comment on or make changes to this bug.