Bug 468035 - ipmitool option parsing broken
ipmitool option parsing broken
Status: CLOSED DUPLICATE of bug 466893
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
5.3
All Linux
medium Severity low
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
:
Depends On:
Blocks: 468042
  Show dependency treegraph
 
Reported: 2008-10-22 10:28 EDT by Karel Volný
Modified: 2008-11-05 07:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 07:29:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2008-10-22 10:28:29 EDT
Description of problem:
ipmitool has troubles parsing the options ...

Version-Release number of selected component (if applicable):
OpenIPMI-tools-2.0.6-9.el5

How reproducible:
always

Steps to Reproduce:
[root@tornado ~]# ipmitool shell
ipmitool> sol payload enable 1
ipmitool> sol payload enable 1 2
ipmitool> sol payload enable 1 2 3
ipmitool> sol payload enable 1 2 3 4
ipmitool> sol payload enable 1 2 3 4 5
ipmitool> sol payload enable 1 2 3 4 5 6
ipmitool> sol payload enable 1 2 3 4 5 6 7
ipmitool> sol payload enable 1 2 3 4 5 6 7 8
ipmitool> sol payload enable 1 2 3 4 5 6 7 8 9
ipmitool> sol payload enable 1 2 3 4 5 6 7 8 9 10
  
Actual results:
no error (nor success) is reported

Expected results:
ipmitool writes error messages for wrong options count/format

Additional info:
see also bug #253735
Comment 4 Jan Safranek 2008-11-05 07:29:04 EST
it's the same bug as #466893 - ipmitool sol payload did not check number of arguments.

*** This bug has been marked as a duplicate of bug 466893 ***

Note You need to log in before you can comment on or make changes to this bug.