Bug 468091 - RHN proxy install documentation issues
RHN proxy install documentation issues
Status: CLOSED DEFERRED
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
510
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Ha
Jeff Browning
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 14:42 EDT by Andy Jennings
Modified: 2014-08-04 18:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 12:38:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Jennings 2008-10-22 14:42:14 EDT
I believe I have a functioning Red Hat Proxy. I started the installation from scratch and found myself and the same spot as with the previous server - 404 Not Found when the client communicated with the Proxy Server. After digging through some of the Apache config files I found the Location directive which defined /XMLRPC as the path the client should be requesting. As the documentation that I had found was not clear on configuring the client I had simply defined the serverURL as http://proxy.rhn.internal without any path information. I guess the default is to look for /RPC2. When I added the /XMLRPC the two servers started talking properly.
 
Some additional issues I had with the documentation:
 
1. In the RHN Dashboard when activating the proxy for the system in question there is a link to the installation instructions, version 3.6. There are a few places during this process that point to the instructions, all of which are version 3.6.
 
2. The installation instructions have you install the rhns-certs-tools package, but as part of activating the proxy this package is removed (or that version). I'm sure the process is just placing a specific other version on the system, but the message is just that it needs to be removed and is therefore a bit confusing.
 
3. Within the 5.1 installation instructions there is a lot of talk about a monitoring feature, but I never saw that option when I deployed the proxy. Maybe its something we're not paying for, but again, the instructions assume that option is there and I didn't see it.
 
4. During several phases of the process other documentation is reffered to, but no links are given. It was difficult at times to track down the appropriate secondary documentation (ie. configuring SSL, which I found because Billy sent me the link).
 
Overall, there seems to be some serious issues with how the documentation is presented on the site. I went after the documentation three different ways, Google, RHN Dashboard, and support and each method got me a different version of the documentation. Some of the KB Articles that Billy sent would have been much more useful if they were linked to from within the installation instructions, or integrated into those instructions.
 
Just wanted to share my most recent experience with the hopes that it will help you to better understand your client's needs and perhaps work on improving your service.
Comment 1 Clifford Perry 2008-11-20 12:45:25 EST
Hi there, 
Did you use the documentation for RHN Proxy found here:

http://www.redhat.com/docs/manuals/satellite/

The Monitoring part is only for RHN Proxy deployed against RHN Satellite. 

Did you read and review the client configuration guide, which talked about setting up client configuration?

I wish I knew exactly what information is given to a customer when they purchase a RHN Proxy to determine if your new introduction is the same as customers can experience. 

So. Based on what you know, is there specific items (from above) you would like to get addressed within the documentation which we control and publish on www.redhat.com/docs/ for the Proxy product? 

Thanks,
Cliff.
Comment 2 Andy Jennings 2008-12-09 18:21:22 EST
I spoke to the client and they felt that they had to jump between different guides to get the information requested. I don't have any more info than that. The client asked me to mention their frustration with the docs.
Comment 3 Clifford Perry 2008-12-16 15:45:15 EST
I am going to close this bug out with no defined actions requested. 

I am also going to send an email to the Satellite Release Team directed to our Product Management/Marketing team indicating the possible need for a RHN Proxy Deployment/Best Practices/Quick Start guide to help new users of RHN Proxy beyond installation to use it. 

Cliff.

Note You need to log in before you can comment on or make changes to this bug.