Bug 468095 - Hitting "r" key turns on scroll-lock led on keyboard, enter or " turns it off
Hitting "r" key turns on scroll-lock led on keyboard, enter or " turns it off
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 14:53 EDT by Dennis Jacobfeuerborn
Modified: 2011-02-16 00:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 16:56:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of "xkbcomp -xkb :0 out.xkb" (56.68 KB, text/plain)
2008-10-23 09:07 EDT, Dennis Jacobfeuerborn
no flags Details
Xorg logfile (15.00 KB, text/plain)
2008-10-23 09:11 EDT, Dennis Jacobfeuerborn
no flags Details

  None (edit)
Description Dennis Jacobfeuerborn 2008-10-22 14:53:24 EDT
Everytime I hit the "r" key on the key the scroll-lock led on the keyboard lights up. When I press either the return key or " (shift+2) it gets turned off.

I'm using a regular ps/2 keyboard with a german layout:
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
Comment 1 Peter Hutterer 2008-10-22 20:09:04 EDT
please attach your Xorg.log, your xorg.conf (if you have one), the output of setxkbmap -print and finally the out.xkb file after running xkbcomp -xkb :0 out.xkb. Thanks.

also, what version of xserver and evdev are you running?
Comment 2 Dennis Jacobfeuerborn 2008-10-23 09:07:57 EDT
Created attachment 321278 [details]
result of "xkbcomp -xkb :0 out.xkb"
Comment 3 Dennis Jacobfeuerborn 2008-10-23 09:11:08 EDT
Created attachment 321279 [details]
Xorg logfile

xorg.conf (yes, that's the entire xorg.conf):
============== SNIP ===============
Section "Device"
        Driver          "nvidia"
        Identifier      "Videocard0"
        Option          "PixmapCacheSize" "1000000"
        Option          "AllowSHMPixmaps" "0"
EndSection
============== SNIP ===============

Output of "setxkbmap -print":
============== SNIP ===============
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwertz)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+de(nodeadkeys)+inet(evdev)+group(alts_toggle)"      };
        xkb_geometry  { include "pc(pc105)"     };
};
============== SNIP ===============
Comment 4 Peter Hutterer 2008-10-24 01:40:03 EDT
I don't see anything out of the ordinary there, so lets try a few things:

- does it happen if you replace nvidia with nv?
- does it happen with another layout?
- does it happen with a test user (to ensure there are no stale settings)
- does it happen if you add a Section "ServerFlags" with Option "AutoAddDevices" "off"?
- other than that, does the keyboard work alright?
Comment 5 Dennis Jacobfeuerborn 2008-11-19 16:56:29 EST
I'm no longer seeing this so it looks like one of the updates in the last few days has fixed the problem.
Comment 6 Anthony Symons 2009-05-19 04:03:11 EDT
I just wanted to report that im seeing this right now on fedora 10. My video card crashed earlyer today and since X restarted 'r' lights scroll lock and 'enter' or '2' turns it off. This is with a regular us layout keyboard. 

Im also seeing lots of these in /var/log/messages:

May 19 17:30:26 ant init: tty2 main process (12036) killed by QUIT signal
May 19 17:30:26 ant init: tty2 main process ended, respawning
May 19 17:30:29 ant init: tty2 main process (12038) killed by QUIT signal
May 19 17:30:29 ant init: tty2 main process ended, respawning

I suspect the issue might be related. 

Im also not worried about it as I suspect that it'll go away at the next reboot. If it doesnt I'll report back and re-open the bug.
Comment 7 Matěj Cepl 2009-05-19 05:29:56 EDT
(In reply to comment #6)
> Im also not worried about it as I suspect that it'll go away at the next
> reboot. If it doesnt I'll report back and re-open the bug.  

Please, file rather new one and don't forget to attach /var/log/Xorg.0.log, /var/log/dmesg, and (if any exists) /etc/X11/xorg.conf.
Comment 8 Ralph Loader 2011-02-16 00:51:56 EST
FYI, this has regressed for me, new bug 677862.

Note You need to log in before you can comment on or make changes to this bug.