Bug 46810 - Anaconda crashes at bootloader with Grub
Anaconda crashes at bootloader with Grub
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 46808 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-30 19:47 EDT by Ray Curtis
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 22:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is a real traceback thanks to the new anaconda-update.img (1.67 KB, text/plain)
2001-07-02 19:56 EDT, Ray Curtis
no flags Details

  None (edit)
Description Ray Curtis 2001-06-30 19:47:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010622

Description of problem:
Duting install of beta1 using a 586 with multiple disks using sda
as the install disk everything seems to go fine until I get to the
bootloader then it crahes.

How reproducible:
Always

Steps to Reproduce:
1. just do a full install
2.
3.
	

Actual Results:  Handwritten Traceback:
File "/usr/bin/anaconda", line 561, in ? intf.run (id,dispatch)
File "/usr/lib/anaconda/text.py",line 386, in run dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py",line120, in gotoNext self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 185, in moveStep 
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/bootloader.py", line 442 in writeBootloader
justConfigfile)
File "/usr/lib/anaconda/bootloader.py", line 355, in write chainlist,
defaultDev, justConfig)
File "/usr/lib/anaconda/bootloader.py", line 203, in write Grub
cmd = "root %s\ninstall %s/i386-redhat/stage1 d (%s) %s/i386-redhat/
stage2 p%s%s/grub.conf" % \
File "/usr/lib/anaconda/bootloader.py", line 486, in grubbyDiskName
return "hd%d" % drives.index(name)
ValueError: list.index(x): x not in list
> /usr/lib/anaconda/bootloader.py(486)grubbyDiskName()
-> return "hd%d" % drives.index(name)
  

Additional info:
Comment 1 Alexander L. Belikoff 2001-06-30 21:45:14 EDT
In my case, it dumped a traceback during the post-install. It DIDN'T seem to
save   the crash info to a floppy although I asked it to do so. After the
reboot, the boot loader wasn't installed and fstab was empty.

BTW, I requested a full install to a spare partition (hdb1) on an already
functional system w/ GRUB installation to the partition (NOT MBR)
Comment 2 Brent Fox 2001-07-02 10:56:12 EDT
*** Bug 46808 has been marked as a duplicate of this bug. ***
Comment 3 Ray Curtis 2001-07-02 19:56:33 EDT
Created attachment 22507 [details]
Here is a real traceback thanks to the new anaconda-update.img
Comment 4 Nitin Dahyabhai 2001-07-02 22:34:32 EDT
/dev/sda, an empty ZIP drive, is the only SCSI disk on my system, but got the
same failure writing GRUB to /dev/hda3 .
Comment 5 Jeremy Katz 2001-07-09 16:37:31 EDT
Should be fixed in CVS.  Please reopen this bug if you see this in beta2 or later
Comment 6 Brent Fox 2001-07-24 17:14:12 EDT
*** Bug 48890 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.