Bug 468127 - Blank X screen with kernel-PAE, works with i686 kernel
Blank X screen with kernel-PAE, works with i686 kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 470985 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 21:11 EDT by Joe Ammond
Modified: 2008-12-27 05:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-26 11:03:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from PAE kernel (29.88 KB, application/octet-stream)
2008-10-22 21:11 EDT, Joe Ammond
no flags Details
dmesg from -PAE kernel (38.66 KB, text/plain)
2008-10-22 21:11 EDT, Joe Ammond
no flags Details
Xorg.0.log from i686 kernel (85.34 KB, application/octet-stream)
2008-10-22 21:12 EDT, Joe Ammond
no flags Details
dmesg from i686 kernel (39.25 KB, text/plain)
2008-10-22 21:12 EDT, Joe Ammond
no flags Details

  None (edit)
Description Joe Ammond 2008-10-22 21:11:02 EDT
Created attachment 321227 [details]
Xorg.0.log from PAE kernel

Description of problem:
If I boot my laptop with kernel-PAE, X starts to probe the hardware but stays blank. In dmesg I see: 

[drm:i915_driver_load] *ERROR* failed to enable MSI
[drm] Initialized i915 1.6.0 20080730 on minor 0

The keyboard is unresponsive as well. The machine is reachable from the network during this.

Hardware is:
HP Compaq 6710b laptop
Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz
4G RAM
i965 chipset

When booted with a non-PAE kernel, X works fine.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.27.3-30.rc1.fc10.i686

How reproducible:
Very.

Steps to Reproduce:
1. Install kernel-PAE
2. Boot kernel-PAE
  
Actual results:
X fails to start.

Expected results:
X starts.

Additional info:
Comment 1 Joe Ammond 2008-10-22 21:11:42 EDT
Created attachment 321228 [details]
dmesg from -PAE kernel
Comment 2 Joe Ammond 2008-10-22 21:12:15 EDT
Created attachment 321229 [details]
Xorg.0.log from i686 kernel
Comment 3 Joe Ammond 2008-10-22 21:12:37 EDT
Created attachment 321230 [details]
dmesg from i686 kernel
Comment 4 Jürgen Botz 2008-11-16 14:37:11 EST
*** Bug 470985 has been marked as a duplicate of this bug. ***
Comment 5 Jürgen Botz 2008-11-16 14:44:53 EST
Ok, I have the same problem on a Thinkpad T61 model 8897-CTO (Intel 965 graphics, 1400x1050 display) with 4GB RAM.  Anaconda installed only the PAE kernel (presumably because I have 4GB) and until seeing this entry I hadn't thought of trying a non-PAE kernel, so I filed bug # 470985.  Now I have, and it works, so I can confirm that this is an issue with the PAE kernel and I've marked my prior report a duplicated of this one.

It seems likely that everyone with more the 3GB and i965 graphics will encounter this when installing F10, so I think this bug should be bumped up in priority.
Comment 6 Jürgen Botz 2008-11-16 17:25:34 EST
kernel 2.6.27.5-109 appears to resolve the issue.
Comment 7 Michael Wise 2008-11-19 06:34:21 EST
kernel 2.6.27.5-113 has fixed the problem of a blank screen.  now when compiz is enabled as soon as I log in, the screen goes white.  I'm running on a Thinkpad T61 with and intel 965 graphics.  If this is not related, I'll be happy to open a new bug.
Comment 8 Jürgen Botz 2008-11-19 08:18:21 EST
I get the same thing with compiz, and I also get an X lockup when trying to switch users (i.e. starting a second X server).  The lockup looks and feels the same as the one we had on starting the first X server with kernels release < -109.
Comment 9 Jürgen Botz 2008-11-19 11:14:43 EST
Ok, just to be clear...

- With PAE kernel compiz doesn't work, gives white screen and locks
  up.  With regular kernel it works.
- With PAE kernel second Xserver (for user-switch) locks up while
  starting, with regular kernel it works.
Comment 10 Bug Zapper 2008-11-25 23:08:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Joe Ammond 2008-12-26 11:03:34 EST
The latest round of updates fixes this problem for me. I'd say this can be closed.
Comment 12 Jürgen Botz 2008-12-27 05:17:18 EST
Not fixed, just worked-around.  Intel graphics still doesn't work correctly with PAE kernel (for example framerate in glxgears in PAE is about 20% of framerate in standard kernel.)

This is certainly an upstream issue, but it should be in Fedora bugzilla to track it.

Note You need to log in before you can comment on or make changes to this bug.