Bug 468132 - No DNS name resolution in %post
No DNS name resolution in %post
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 23:21 EDT by Orion Poplawski
Modified: 2008-10-30 13:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 13:30:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-10-22 23:21:25 EDT
Description of problem:

In my %post scripts, I restore state from a backup by mounting a NFS directory.  With current rawhide, this is now failing:

+ mount saga:/export/backup1 /data/backup1
mount.nfs: DNS resolution failed for saga: Temporary failure in name resolution

+ cat /etc/resolv.conf
search cora.nwra.com

I can work around this if needed, but this used to work fine with anything special.

Version-Release number of selected component (if applicable):
11.4.1.50
Comment 1 Orion Poplawski 2008-10-23 11:37:59 EDT
I think this is also breaking my "authconfig --ldaploadcacert=http:" kickstart line.  This is more problematic.
Comment 2 David Cantrell 2008-10-24 21:57:21 EDT
The %post scripts are executed in a chroot in /mnt/sysimage after the install completes.  What I imagine we should do is copy the installer copy of /etc/resolv.conf to /mnt/sysimage/resolv.conf.

Testing that now.
Comment 3 David Cantrell 2008-10-27 20:56:41 EDT
Copying the resolv.conf file used during installation over to /mnt/sysimage does the trick.  That's what we were doing in network.py, except we were writing out the data we had in the NetworkDevice object.  What we were lacking was the DNS information, so we were only writing out a search line.

Fix will be in anaconda-11.4.1.52-1.
Comment 4 Orion Poplawski 2008-10-30 13:30:56 EDT
Works for me.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.