Bug 468138 - Booting from SAN using DM Multipath is explicitly not certified by EMC
Booting from SAN using DM Multipath is explicitly not certified by EMC
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 01:28 EDT by Andrew Hardy
Modified: 2010-01-11 21:44 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 17:34:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Hardy 2008-10-23 01:28:05 EDT
Description of problem:
The EMC interoperability matrix (http://www.emc.com/collateral/elab/emc-support-matrices.pdf) explicitly rules out the use of Device Mapper Multipath for booting from an EMC SN. 

Version-Release number of selected component (if applicable):
ANY

How reproducible:
Various customers have had issues trying it, such as Optus and Corporate Express.  I don't have the case numbers at hand.  Frank Feldmann asked me to raise this as a bug.  

Steps to Reproduce:
1.  Try using DM MPIO for booting from the SAN as an alternative to EMC Powerpath.
2.
3.
  
Actual results:
DM MPIO causes initrd issues when replicating the R1 to an R2.  System fails to boot.  EMC responded to customer advising that DM MPIO failed an RPQ for BFS.  Wondering if this is known to our engineering team and if there is a Red Hat position on this. 

Expected results:
You should be able to replace EMC Powerpath with DM MPIO as per our Red Hat value prop.  It should generally work since it's generally stated. 

Additional info:
N/A
Comment 2 Michael Hagmann 2009-01-12 17:19:54 EST
Hi Andrew

we are explicit allowed from EMC to boot from SAN with DM MPIO! You need that definitiv for a SAP enviroment because they don't allow you to use EMC Powerpath ( because it's a binary Module only ).

you need a "individual release approval from EMC" named RPQ, but it was no Problem to get one from EMC.

from SAP Note 800326 :Since EMC PowerPath is distributedas binary only modules, SAP does not support SAP software running onservers where EMC PowerPath is active (see note 784391).

Mike

RPQ looks like this:

BEST REASONABLE EFFORT (BRE):
Excluding base configuration, the first call for support should be handled by RedHat. 
Upgrade 1: 
- Configurations as set forth in RPQ XXXXXX 
- HP DL585 servers 
- HP FC1142S (QLogic QLE2460) HBA with BIOS 1.24 (Available in the EMC-approved section of the QLogic website. http://www.qlogic.com); and driver 8.01.04-d8 (integrated into the kernel) - QLogic QLA2342 HBA with BIOS 1.52 (Available in the EMC-approved section of the QLogic website. http://www.qlogic.com); and driver 8.01.04-d8 (integrated into the kernel) 
- EMC CLARiiON CX3-80 with FLARE R24 
- Brocade 3900 and 4900 FC-SW 
- RHEL 4.5 (2.6.9-55.EL, 2.6.9-55.0.2.EL., 2.6.9-55.0.6.EL, 2.6.9-55.0.9.EL, and 2.6.9-55.0.12.EL) available in ia32 and x86_64 
- RHCS as packaged with RHEL 4.5 
- LVM as packaged with RHEL 4.5 
- GFS as packaged with RHEL 4.5 
- Linux native DM-MPIO as packaged with RHEL 4.5 
- Atix shared root filesystem as supported by Red Hat and Atix 
Upgrade 2: 
- Configurations as set forth in RPQ XXXXXX
- HP DL585 servers 
- HP FC1142S (QLogic QLE2460) HBA with BIOS 1.24 (Available in the EMC-approved section of the QLogic website. http://www.qlogic.com); and driver 8.01.07-d4 (integrated into the kernel) 
- QLogic QLA2342 HBA with BIOS 1.52 (Available in the EMC-approved section of the QLogic website. http://www.qlogic.com); and driver 8.01.07-d4 (integrated into the kernel) 
- EMC CLARiiON CX3-80 with FLARE R24 
- Brocade 3900 and 4900 FC-SW 
- RHEL 4.6 (2.6.9-67.EL, 2.6.9-67.0.1.EL, 2.6.9-67.0.4.EL) available in ia32 and x86_64 
- RHCS as packaged with RHEL 4.6 
- LVM as packaged with RHEL 4.6 
- GFS as packaged with RHEL 4.6 
- Linux native DM/MPIO as packaged with RHEL 4.6 
- Atix shared root filesystem as supported by Red Hat and Atix 
Note 1:
- EMC nor Red Hat support a cluster consisting of heterogeneous RHEL installs. All servers in the same cluster must be configured with the same installation of the operating system/cluster software in order to function properly. 
Note 2:
- Though this configuration is not officially ELab tested, EMC will make every effort to work with Red Hat to resolve any issues that may arise. However, first call for support should be handled by RedHat. 
Note 3:
- It is strongly recommended that all servers be dual attached and that path failover software be used to ensure that the customer is running in an HA environment.

Note You need to log in before you can comment on or make changes to this bug.