Bug 468144 - 2 masters found in a 2-node cluster
2 masters found in a 2-node cluster
Status: CLOSED DUPLICATE of bug 430264
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 03:48 EDT by Qian Shen
Modified: 2015-10-25 21:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 13:20:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Node1's sysreport (2.36 MB, application/x-bzip2)
2008-10-23 03:53 EDT, Qian Shen
no flags Details
The Node2's sysreport (1.91 MB, application/x-bzip2)
2008-10-23 03:56 EDT, Qian Shen
no flags Details

  None (edit)
Description Qian Shen 2008-10-23 03:48:18 EDT
Description of problem:

A 2-nodes cluster with a qdisk. Now each of the 2 nodes becomes a master of qdisk. 

Node1: 
Oct 20 09:47:04 pnclrap1 clurgmgrd: [22632]: <info> Executing /etc/cluster/rhcs/pnclrap1.sh status 
Oct 20 09:47:31 pnclrap1 qdiskd[22456]: <notice> Score insufficient for master operation (0/1; max=1); downgrading 
Oct 20 09:47:33 pnclrap1 qdiskd[22456]: <info> Node 1 shutdown 
Oct 20 09:47:33 pnclrap1 qdiskd[22456]: <notice> Score sufficient for master operation (1/1; max=1); upgrading 
Oct 20 09:47:34 pnclrap1 qdiskd[22456]: <info> Assuming master role 
Oct 20 09:47:40 pnclrap1 qdiskd[22456]: <crit> Critical Error: More than one master found! 
Oct 20 09:47:40 pnclrap1 qdiskd[22456]: <crit> A master exists, but it's not me?! 

Node 2:
Oct 20 09:47:31 pnclcfm1 qdiskd[7883]: <info> Node 2 shutdown 
Oct 20 09:47:32 pnclcfm1 qdiskd[7883]: <notice> Score insufficient for master operation (0/1; max=1); downgrading 
Oct 20 09:47:34 pnclcfm1 qdiskd[7883]: <notice> Score sufficient for master operation (1/1; max=1); upgrading 
Oct 20 09:47:35 pnclcfm1 qdiskd[7883]: <info> Assuming master role 
Oct 20 09:47:38 pnclcfm1 qdiskd[7883]: <crit> Critical Error: More than one master found! 
Oct 20 09:47:39 pnclcfm1 qdiskd[7883]: <info> Node 2 is the master 
Oct 20 09:47:39 pnclcfm1 qdiskd[7883]: <crit> Critical Error: More than one master found! 


Version-Release number of selected component (if applicable):
OS: RHEL 4.4


How reproducible:
It's a production environment, and the errors still exists.
Comment 1 Qian Shen 2008-10-23 03:53:54 EDT
Created attachment 321248 [details]
The Node1's sysreport
Comment 2 Qian Shen 2008-10-23 03:56:43 EDT
Created attachment 321251 [details]
The Node2's sysreport
Comment 3 Lon Hohberger 2008-12-03 13:20:43 EST

*** This bug has been marked as a duplicate of bug 430264 ***

Note You need to log in before you can comment on or make changes to this bug.