Bug 468225 - tcsh problems in fedora 9
tcsh problems in fedora 9
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tcsh (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 12:35 EDT by Jim Peterson
Modified: 2008-12-01 11:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 11:11:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Peterson 2008-10-23 12:35:18 EDT
Description of problem:
This is for installation of Fedora 9 on Dell D630.
I have the following problems:

1.  tcsh does not work correctly.
    I began with tcsh-6.15-5.fc9.i386.
    I prefer to use tcsh but I have had to
    revert to bash because of the problems I report here.
    
a.  I like to start acroread in a konsole window
    when I am generating pdfs.  When I run tcsh,
    I get this behavior:
	
[petersj@inkapod CalcBioII]$ acroread CalcBioII.pdf&
[2] 7277
[petersj@inkapod CalcBioII]$ /usr/bin/acroread: symbol lookup error: /usr/lib/gtk-2.0/2.10.0/engines/libqt4engine.so: undefined symbol: _ZN9QListData7detach2Ev

[2]    Exit 127                      acroread CalcBioII.pdf
[petersj@inkapod CalcBioII]$

It doesn't matter if I just start acroread either.

[petersj@inkapod CalcBioII]$ acroread&
[2] 7359
[petersj@inkapod CalcBioII]$ /usr/bin/acroread: symbol lookup error: /usr/lib/gtk-2.0/2.10.0/engines/libqt4engine.so: undefined symbol: _ZN9QListData7detach2Ev

[2]    Exit 127                      acroread
[petersj@inkapod CalcBioII]$

    This doesn't happen if I exit tcsh and run bash.
    Also I CAN start acroread from the file menu in kde4.
    I can start acroread from the konsole window running
    tcsh in gnome though.
    
b.  I have the same behavior if I try to start firefox in
a konsole window.

[petersj@inkapod CalcBioII]$ firefox&
[2] 7617
[petersj@inkapod CalcBioII]$ /usr/lib/firefox-3.0.2/firefox: symbol lookup error: /usr/lib/gtk-2.0/2.10.0/engines/libqt4engine.so: undefined symbol: _ZN9QListData7detach2Ev

[2]    Exit 127                      firefox
[petersj@inkapod CalcBioII]$

Again, if I exit tcsh and run bash, this is ok.
I can start firefox from the file menu in kde4.
I can start acroread from the konsole window running
tcsh in gnome though.

c.  I updated packages today and couldn't restart kde
as I received an error 

couldn't start kdestartupconfig4

early in the boot process and I fell back to the login screen.
I logged back in using gnome and set my default shell to bash
and then I could log in using kde.

d.
Auto session save doesn't seem to work in both kde and gnome.

e. 
I installed
tcsh-6.15-6.fc10.i386.rpm

and the behavior is still the same.

Note, none of these problems with tcsh occur when
I use gnome.  The problems seems to be with kde4 and tcsh.

I am attaching my current rpm files

Let me know if there is anything I can do.

Jim Peterson

Version-Release number of selected component (if applicable):
tcsh-6.15-5.fc9.i386 
and
tcsh-6.15-6.fc10.i386.rpm

How reproducible:

Easy.  Just run tcsh in kde4 as your shell and try to
start up firefox or acroread within the shell.



Additional info:
I attached a list of my current rpms if that might help.
Comment 1 Jaroslav Reznik 2008-11-05 10:40:43 EST
c) I can't reproduce it with tcsh-6.15-5.fc9.x86_64
Comment 2 Jim Peterson 2008-11-05 10:50:30 EST
Well, I use  

tcsh-6.15-6.fc10.i386.rpm

which is 32 bit and you used 64 bit.
Comment 3 Jaroslav Reznik 2008-11-06 04:22:12 EST
(In reply to comment #2)
> Well, I use  
> 
> tcsh-6.15-6.fc10.i386.rpm

Why are you using F10 development package in F9?
 
> 
> which is 32 bit and you used 64 bit.

I tried it with tcsh-6.15-6.fc10.i386 on F10 and it's working. Sorry I don't have F9 installation on i386 but I suppose it will be same.
Comment 4 Vitezslav Crhonek 2008-11-06 06:02:35 EST
a), b) Library (libqt4engine.so) issue. You have probably older/newer library installed than your firefox/acroread needs. It seems that you have installed two or more library versions (because it works from bash, so right version is somewhere too). You should try to clean your system a bit (or set LD_LIBRARY_PATH from bash in tcsh to the same value). Definitely not a bug in tcsh.

d) Please do more detailed bug report to appropriate component(s).

Note You need to log in before you can comment on or make changes to this bug.