Bug 468249 - Compiz won't start on Intel 4500MHD (Cantiga)
Compiz won't start on Intel 4500MHD (Cantiga)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 14:54 EDT by Tomasz Torcz
Modified: 2009-09-06 03:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My X log (91.72 KB, text/plain)
2008-10-23 14:54 EDT, Tomasz Torcz
no flags Details
output of glxinfo (7.06 KB, text/plain)
2008-10-23 14:55 EDT, Tomasz Torcz
no flags Details
Xorg.0.log from powerbook g4 during 'desktop-effects' (101.96 KB, text/plain)
2008-12-15 20:02 EST, Gabriel Somlo
no flags Details
output of glxinfo on powerbook g4 laptop (7.18 KB, text/plain)
2008-12-15 20:03 EST, Gabriel Somlo
no flags Details

  None (edit)
Description Tomasz Torcz 2008-10-23 14:54:27 EDT
Created attachment 321326 [details]
My X log

Description of problem:
% compiz --replace ccp
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Yet:
% glxinfo|grep GLX_EXT_texture_from_pixmap
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap



Version-Release number of selected component (if applicable):
up-to-date rawhide

How reproducible:
Always

00:02.0 VGA compatible controller: Intel Corporation Cantiga Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Cantiga Integrated Graphics Controller (rev 07)
Comment 1 Tomasz Torcz 2008-10-23 14:55:12 EDT
Created attachment 321327 [details]
output of glxinfo
Comment 2 Bug Zapper 2008-11-25 23:09:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Gabriel Somlo 2008-12-15 20:00:08 EST
This bug also seems to be a duplicate of 364571. I can reproduce it on my
PowerBook G4 (running F10 ppc).

Starting desktop-effects from the command line, I click 'enable desktop
effects'. The screen goes blank, but the cursor changes depending on which
window (which I can't see) it hovers over. If I move it to the upper-right
corner of the screen, I suddenly see rectangles taking shape (much like the
MacOS expose behavior), but only the desktop icon belonging to each application
is visible in the lower-right corner of each rectangle. If I click on one of
the rectangles, they start growing back to the size of their original window
(again, like Expose), and then the screen goes white again.

After a few seconds, the whole thing times out, and I end up with the original
desktop-effects window (with the effects still disabled). The terminal I started it from shows this output:


[tester@mater ~]$ desktop-effects
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't  registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't  registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't  registered


If I run compiz directly, I don't get a timeout, but rather an immediate error
message:
[tester@mater ~]$ compiz --ignore-desktop-hints glib gconf --replace
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

I'm attaching my Xorg.0.log, with a comment (prefaced by '####') delineating
where during the logging process I ran desktop-effects.


Here's the output of lspci showing my video card:
0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility
Radeon 9600 M10]

And here's '/proc/cpuinfo':

processor       : 0
cpu             : 7447A, altivec supported
clock           : 749.999000MHz
revision        : 0.1 (pvr 8003 0101)
bogomips        : 36.73
timebase        : 18432000
platform        : PowerMac
model           : PowerBook5,4
machine         : PowerBook5,4
motherboard     : PowerBook5,4 MacRISC3 Power Macintosh
detected as     : 287 (PowerBook G4 15")
pmac flags      : 0000001b
L2 cache        : 512K unified
pmac-generation : NewWorld
Comment 4 Gabriel Somlo 2008-12-15 20:02:19 EST
Created attachment 327048 [details]
Xorg.0.log from powerbook g4 during 'desktop-effects'

comment line prefaced by '#####' delimits what was logged before and after I ran
'desktop-effects'
Comment 5 Gabriel Somlo 2008-12-15 20:03:01 EST
Created attachment 327049 [details]
output of glxinfo on powerbook g4 laptop
Comment 6 Tomasz Torcz 2008-12-17 15:18:11 EST
Running "compiz-gtk" works. Plain "compiz" still don't.
Comment 7 Valent Turkovic 2009-06-30 08:08:22 EDT
Is there any progress with this issue?

Has anybody tested Intel 4500 in Fedora 11? I'm getting soon laptop with this card in it and would love to be able to use compiz.

Currently only Intel I had zero issues with compiz is Intel 945 chip, with newer 965 the performance is much lower ;(
Comment 8 Tomasz Torcz 2009-06-30 09:31:58 EDT
As noted in #6, using "compiz-gtk" instead of plain "compiz" works. Using configuration applet for enabling Desktop Effects works also. I believe this bug can be closed.
Comment 9 Valent Turkovic 2009-06-30 09:47:20 EDT
Thank you for quick reply!

ps. there is also a great Compiz Wiki, please consider adding your expertise which graphics cards work and which don't to this page. I have some experence with Intel 945, 946 and 915 so I added that info on that Wiki page: http://wiki.compiz-fusion.org/Hardware/

Cheers!
Comment 10 Vedran Miletić 2009-09-06 03:41:58 EDT
Closing per comment #8.

Note You need to log in before you can comment on or make changes to this bug.